[SOLVED] Espruino 1.94 on ESP8266 12E does not work

Posted on
  • Hi All,

    I'm a newbie to this, so please bear with me.
    Trying to load the latest Espruino firmware 1.94 to my ESP8266 12E boards. It came with Node MCU and I used it to flash Arduino programs through it's IDE and it worked perfectly.
    I have 3 ESP8266 units and tried flashing Espruino on all of them and had no luck.

    My Os is Windows 10 Pro (64bit)


    • I do not see any flashing errors. All flashing programs seems ends successfully.
    • Espruino IDE communications Baud rate is set to 115200
    • At first connect from Espruino IDE, it says disconnected (see picture).
    • At second connect from IDE, it connects. But on the terminal prompt I cannot type anything. prompt does not accept any text (see picture).
    • I used PuTTY, still the same. I do not see a thing. Cannot type any text at the prompt.
      See attached pictures please (see picture).

    Tools used to flash firmware:

    • nodemcu-flasher (see pictures for it's configurations)
    • esptool.py
    • For python I use Enthought Canopy
    • firmware I used for my board is "espruino_1v94_esp8266_4mb"
    • I did a erase flash. command line for that

      python "../../esptool/esptool.py"  --port COM4 erase_flash
      esptool.py v2.2-dev
      Detecting chip type... ESP8266
      Chip is ESP8266EX
      Uploading stub...
      Running stub...
      Stub running...
      Erasing flash (this may take a while)...
      Chip erase completed successfully in 8.3s
      Hard resetting...

    Command line I used to to flash to board,

    python "../../esptool/esptool.py" --port COM4 --baud 115200 write_flash --flash_freq 80m --flash_mode qio --flash_size 4MB 0x0000 "boot_v1.6.bin" 0x1000 espruino_esp8266_user1.bin 0x3FC000 esp_init_data_default.bin 0x3FE000 blank.bin
    esptool.py v2.2-dev
    Detecting chip type... ESP8266
    Chip is ESP8266EX
    Uploading stub...
    Running stub...
    Stub running...
    Configuring flash size...
    Flash params set to 0x004f
    Compressed 3856 bytes to 2763...
    Wrote 3856 bytes (2763 compressed) at 0x00000000 in 0.3 seconds (effective 119.6 kbit/s)...
    Hash of data verified.
    Compressed 480292 bytes to 336714...
    Wrote 480292 bytes (336714 compressed) at 0x00001000 in 30.0 seconds (effective 128.1 kbit/s)...
    Hash of data verified.
    Compressed 128 bytes to 75...
    Wrote 128 bytes (75 compressed) at 0x003fc000 in 0.0 seconds (effective 53.9 kbit/s)...
    Hash of data verified.
    Compressed 4096 bytes to 26...
    Wrote 4096 bytes (26 compressed) at 0x003fe000 in 0.0 seconds (effective 2340.6 kbit/s)...
    Hash of data verified.
    Hard resetting...

    5 Attachments

    • 01.png
    • 02.png
    • 03.png
    • 04.png
    • 05.png
  • After flashing, on windows 10, I have found that you need to unplug the USB cable and then plug it in again.

    Then you will be able to connect with the ide or putty.

    It is only after a new flash that you have this suitation.

  • Thanks Wilberforce for your reply.
    I have already tried that many times.
    I had even pressed the reset button on my board.
    I even tried flashing using the Flash button on the board. By plugging in the USB while pressing the Flash button.

    This is the board version I have. see attached.

    1 Attachment

    • NodeMCU.jpg
  • Did you make any progress with this issue? i am having the same issue and an extensive google search revealed nothing. It seems that this board has a firmware support yet i dont see a lot of activity around it.

  • sorry nothing yet :(

  • How about trying to flash the single 'combined' file to address 0? That's what I've been doing and it seems to work pretty well.

  • Thanks,
    Where I can find the combined file?

  • Reply

    I've made some progress on this. Please refer to my post.

  • can you delete this forum than or mark it as [SOLVED] in the subject please.

  • @jinantha, did you try to switch qio to dio in espruino-tools command line ?
    you can also try replugging after the erase
    It is mentioned here recently, it helped me : http://forum.espruino.com/comments/13902­968/

  • Why was this mark solved without a solution. THat sucks!

    EDIT wow. this was a very nasty version of me. As you can see from another post I made you guys helped and I now have v2.03 on a ESP8266 and ESP32.

    Great job. and next time ignore the mean people (like myself) We'll be fine.

  • Fri 2019.06.21

    Hi @DamianMontero, I too was a bit puzzled by the chronological mis-match that resulted in the title change.

    Did you by chance follow the link in #8, and follow all those embedded links as well, as there is a solution documented by one individual.

    I see that you may have found a corresponding thread:


    Supporting the great work @Gordon continues to do, with the purchase of Original Authentic boards, will alleviate the headaches attempted with third party boards. Up and running by just plugging them in!

  • @Robin you're absolutely right.

    I have a PiCO (which I gave to my dad)
    I have a Pixl.js (Which is a LOT of fun as a geeky name badge. LOVE IT!)
    And I'm going to get a Wifi board.

    But I was unhappy because I wanted it to present (I have 50 boards I bring to a yearly "node Bot" competition) and wanted Espruino instead of Johnny-Five.
    I did get it working on the 8266 boards and everything is well. Anyone interested can look at post: http://forum.espruino.com/conversations/­335394 Which (to be fair) is posted "(SOLVED)" because It has the solution in there.

    THis is a VERY fun. VERY giving forum. and I thank you all!

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

[SOLVED] Espruino 1.94 on ESP8266 12E does not work

Posted by Avatar for jinantha @jinantha