issue with 1v92 on puck - pulsing leds

Posted on
  • I tried to install the 1v92 firmware on my puck, it seems like it uploads okay, but then all three leds start flashing together (which continues after a reset).

    I've tried it a few times, and tried a new battery - though still the same.

    Reinstalling 1v91 worked okay.

  • Odd - had you been using it for anything else beforehand? Was that one that you'd used with a beta firmware? It might be that the beta firmware had caused some corruption of the memory area that's now needed for the Bluetooth stack.

    Could you try reinstalling 1v91 on it, and then run the following on it via the left-hand side, and then try re-uploading 1v92?

    var f = require("Flash");
    for (var i=119;i>=115;i--) {

    thanks! I'd be interested to hear if anyone else has this problem - I had tried upgrading various 1v91 devices before the release, but I guess things changed around with the beta firmwares and that could cause problems.

  • Thanks @Gordon, Okay, I've re-flashed it with 1v91 (1v91.467 from the firmware list, rather than the beta one). And ran that erasePage script on the left:

    >var f = require("Flash");
    =function () { [native code] }
    >for (var i=119;i>=115;i--) {
    :  print(i);
    :  f.erasePage(i*4096);

    Though the LEDs are flashing the same as before when I update to 1v92.

    Ah, yes - this is the one that I had the beta firmware on.

    One thing - I've been screwing around with the NRF.(set/update)Services quite a lot, so I don't know if that got me in a weird state. (I couldn't get custom services to work - and I was hoping that the firmware update might reset things.)

  • Strange... That all looks good - the services and any stored code should get totally overwritten after doing something like that.

    Are you sure you connected and executed that code on the same Puck.js, and not a different one?

    edit: I literally just tried an update from 1v91 after wiping everything and it seems to work fine. Could you maybe try using a new battery? I guess it's possible that the firmware update itself failed halfway through and that's what is causing the crashes?

  • @Gordon - oh, I may well have written that to the wrong one. Just went through it again and I'm upgraded to 1v92 fine. Thanks so much for your help!

  • No problem - glad it's sorted! :)

  • I haven't worked with my pucks in awhile but this weekend I tried installing the v92 and had the same problem with the 3 flashing leds. But your fix to wipe the flash worked fine and v92 installed correctly. Thanks!

  • FYI, just for the sake of another data point, I just had the same thing.

    I've been using a simple BLE HID controlling script on 1v91.715 for some time. I just flashed it to 1v92, and had the full-on RGB flash and failure to connect. So, DFU back to 1v91, run the erasePage bit and then back up to 1v92... sorted.

  • Wow, strange - would you have installed build previously do you think? That's what I thought the problem was.

  • Duh. Yes, looks like you've told me to do it before...­302573/#comment13553381

    Absolutely no memory of that. :) Moral: don't participate in technical discussions on the internet at two in the morning while heavily medicated.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

issue with 1v92 on puck - pulsing leds

Posted by Avatar for benjaminbenben @benjaminbenben