Espruino bricked

Posted on
  • Is there anything I can do?
    I tried re-flashing the firmware, but the bootloader mode won't initiate.
    I tried every other thing the website told me to do; I looked through the troubleshooting page, tried bootloader mode like 20 times, and of course tried re-connecting it to my mac 2000000 times.

    Also, the board was working for the first few days, until I soldered on the bluetooth module. With the bluetooth module the board worked perfectly fine and it got bricked a few hours later after the soldering.

    I really really really want my espruino board back! Someome PLEASE help me!


    P.S. Also, I have a little solder bridge on my bt module, but with it the bt worked perfectly fine, and so did the board. the bricking happened a few hours later after the mistake. I don;t have a solder wick or pump at hand. I ordered one of each and I'm going to fix it when it gets here.

    1 Attachment

    • Photo on 3-1-17 at 5.38 PM.jpg
  • Personally I'd hold off anything until you get some solder wick - it might be you can fix it quite easily by removing those shorts.

    Do any LEDs come on at all? If they don't it's likely because the 3.3v and GND lines are shorted (you could test with a meter)

  • The red and blue LEDs are dimly lit, so I think my board is stuck in some sort of "permanent reset." I also did a bit more research and found out that the bridged pins are the PCM_CLK and PCM_OUT pins on the HC-05. I don't know what these are, but I think they are the ones causing the bricking. However, if that's true, my board should've stopped working right after soldering the bt module.

  • Those pins on the BT module aren't actually connected to Espruino, so I'm not sure they'd cause huge problems.

    Do you have a volt meter? Could you check the voltage between 3.3v and GND when the board is on?

    What were you doing when you 'bricked' the board? Had you uploaded some particular code?

    It is possible to erase the flash memory used by the bootloader, which would then stop the board from booting. You'd need a USB-TTL converter to re-flash it, but it's about $5 and then the process is relatively easy.

  • Okay, I'll give it a go. Can you give me the link for a good USB-TTL converter and also how to hook up the thing?

  • I'd check volts first.

    Also, what were you doing when it got bricked? I guess it wasn't just sitting there doing nothing - it might help figure out what the problem is.

    Any converter should work. I use these ones:­-to-TTL-UART-Module-5Pin-Serial-Converto­r-STC-Replace-FT232-Module-/262448073893­?hash=item3d1b1fcca5:g:ATcAAOSw9NdXrLfe

    Some of them have driver issues on Windows though (as they use clone chips) - if you have the money, try and buy a branded one like Adafruit or Sparkfun, or use one that definitely mentions FTDI.

    instructions here:­r

  • Thanks!
    I don't have a multimeter or anything similar right now...
    Also, I was just toying around with the bt function on the espruino.
    I just connected to it with my mac's bluetooth, and typed in console.log(), 1 + 3, funcitons, simple commands like that.

  • Strange - nothing like that should cause it problems.

    Before anything else, please can you try a new USB cable? Sounds stupid, but those micro USB cables are often really poor and can break easily. If the power suddenly went very high-resistance it'd explain your problems.

    Also check the two buttons - if one or other has got stuck on somehow, that could explain what you're seeing too.

  • I've tried a lot of usb cables.
    The buttons both work good.

  • Fri 2017.03.03

    While you are patiently waiting for your shipment:

    From #1

    I don;t have a solder wick or pump at hand.

    Another technique you might consider, is this that I use when in a pinch, . . . when a solderpult is not available.

    Lay some newspaper out to catch the solder splash. Wear eye protection. Heat your iron while reviewing the following:

    It is possible with a little practice, to get rid of the solder blob by holding the board firmly in one hand, such that the solder side is facing downward and at a 45 degree angle to the table top. Raise the arm holding the board around six inches in the air. Heat the bridged pins with the iron and as soon as the solder liquifies, no more than one second after, slam your arm onto the table, keeping your wrist locked such that the board doesn't contact the table. The molten solder will keep moving towards the table as the board stops moving. Your arm is absorbing the shock as it stops the movement. When done correctly, you'll splatter the newsprint covering the table with that blob you were attempting to get rid of.

    Practice the movement several times before heating the pins. As a word of caution, too many heat and re-heat attempts may delaminate the pads from the board, or ruin the chips themselves, so only do this as a last resort.

    If you have never done this previously, it might make sense to mask off the other pins, so that no solder splash ends up on other pins making matters worse. Also, put down several sheets of newspaper so as not to damage anything else. Remember it takes a few seconds for the solder to cool, so it will attempt to attach to whatever it comes in contact with. Most of the blob will cool on the newsprint making a really cool frozen-in-time splat. Brings back memories of the solder blob wars we used to have, flinging blobs of solder at each other. Loads of fun, but a stupid idea, . . . but I digress. [Do not try this yourself - although I know some readers might]

    From #5

    Can you give me the link for a good USB-TTL converter

    So that those of us, that have access to other resources may provide you with other relevant possibilities, and are close to you for shipping/handling reasons, what country, continent, time zone are you located?

    Hope these ideas help . . .

  • Hey,
    I've tried a lot of times, everything I found online and what you told me to do.
    nothing works.
    I hooked up a usb-ttl converter and tried reflashing the firmware, but no luck
    same thing with starting bootloader mode; I pressed and held BTN1, then pressed and released RST, but nothing happens.
    The red and blue LEDs just glow dimly, and there's nothing I can do.

  • Sun 2017.03.05


    I've tried a lot of times, everything I found online and what you told me to do. nothing works.

    What is meant by "I've tried a lot of times" . . . . "what you told me to do"?

    Are you referring to the process of re-flashing or the removal of solder from the bridged solder pads?

    Has the solder bridge been removed?

    Is it possible that the correct BTN1 is being pressed and held with a tap on RST, but incorrect orientation may have them reversed?

    Do the Blu and Red LEDs flash at all after the release of RST?

  • I removed the solder bridge
    I did exactly what the site told me - press btn1 and then press and release rst.
    the blue and red leds glow dimly, and there's no way i can turn them off or trigger a reset or anything I think the chip is "locked" in a permanent reset.

  • Have you been able to acquire a VOM to take some voltage measurements?

    Will the WebIDE enable you to connect to the device?

  • Checking with a volt meter would be the best place to start as @Robin says.

    Also, are you able to post higher resolution (non-blurry) pictures of both sides of the board? We might be able to see something that looks wrong.

  • I'm in a similar position (blue-red leds dimly lit, unable to connect in normal mode). I've just measured between 3.3 and GND and got the expected voltage(3.29v). Espruino classic, Rev1.4b
    Just to add, this happened after I flashed v 1.92 over v 1.91. I faced an issue with 1.91 whereas the board would use an older version of the program, despite calling save() from the console.

  • I've just used the stm32loader tool to 1) erase and then 2) write the latest firmware (espruino_1v92.1909_espruino_1r3.bin) that I downloaded yesterday, but the verification (-v) mode fails:

    python Dropbox/Espruino/ -p /dev/ttyACM0 -v ~/Downloads/espruino_1v92.1909_espruino_­1r3.bin
    Read 256 bytes at 0x8034600
    Verification FAILED
    214668 vs 214668
    0x4: 0xad vs 0x35
    0x8: 0xf9 vs 0x89
    0xc: 0xf9 vs 0x89
    0x23ea: 0x1 vs 0xff
    0x23eb: 0x0 vs 0xff
    0x23ec: 0x0 vs 0xff
    0x23ed: 0x0 vs 0xff
    0x23ee: 0x8 vs 0xff
    0x23ef: 0x0 vs 0xff
    0x23f0: 0x4 vs 0xff
    0x23f1: 0x1 vs 0xff
    0x23f2: 0x0 vs 0xff
    0x23f3: 0x0 vs 0xff

    Am I using this right? is it meant to return these many differences? I'm attaching the log

  • I just managed to flash drazzy's bigram firmware and now my Espruino classic is working fine...

  • Interesting... I'll give this a check with 1v92 (I'm pretty sure I did at release time though).

    What's the URL of the firmware that worked?

    The verification step will usually fail when flashing from the command-line, yes - it's notjhing to worry about. The bootloader (in the first 10k of flash) refuses to overwrite itself to avoid bricking itself, so if you try and write the complete image you might find that you get differences shown at addresses below 0x2800 - everything above should be fine though

  • Ok, I just looked into this - seems like there is a problem with the 1v92 WIZnet compile for the Original Espruino. I'll try and get a working version updated.

    However, it is possible to use the 'CC3000' networking version - that appears to work fine (at least for me).

  • Ok, I've just uploaded a new firmware. I'm still not 100% sure what happened there, since checking out the same firmware and rebuilding it with the same compiler seemed to produce a workable image this time.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Espruino bricked

Posted by Avatar for BootySnorkeler @BootySnorkeler