ESP-01 8Mbit as a Pico SHIM

Posted on
  • I have a ESP-01 8Mbit version which comes with AT version


    AT version: 14 2016 18:54:01)
    SDK version:2.0.0(656edbf)
    compile time:Jul 19 2016 18:43:55

    I tried integrating with Espruino Pico board using shim v2.0. but I am getting "Uncaught No 'ready' after AT+RST" . Is there any way I can fix this?

  • Wow, that's new - I didn't know there was a 1.3 version!

    Did you run the 'version checker'?

    I'd be interested to know what it reports (since it also checks baud rate). It might be that the new firmware uses a different baud rate and that's your problem?

  • Thanks @Gordon,

    I ended up using AT version 0.50 and it seems to working OK.


  • Thanks for letting me know! Perhaps version 1.3 was doing something strange

  • seems like latest esp-01 no longer comes with AT 0.25 / 0.50.

    If any stuck then please use the attached firmware and re-flash your esp-01.

    use the following commands

    Change the port if you have different. Oh, also it is for 1MB flash. -p /dev/tty.SLAB_USBtoUART -b 115200 write_flash 0x00000 eagle.flash.bin 0x10000 eagle.irom0text.bin 0x7E000 blank.bin 0xFE000 blank.bin 0xFC000 esp_init_data_default.bin

    1 Attachment

  • Thanks! Is that the 0.50 firmware? I'll stick it on the main Espruino site.

    It'd be interesting to see why the new firmware doesn't work though - it could just be a different baud rate I guess.

  • Hi @Gordon, I have re-uploaded the attachment from espressif website. This is the one I tested and worked.

    I don't think it is the baud rate, I did a few debugging, it seems like it is problem detecting the "ready"

    Hope it helps.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

ESP-01 8Mbit as a Pico SHIM

Posted by Avatar for navas @navas