Two pucks - one not working?

Posted on
  • I have two pucks. I can connect to one with nRF Connect, send commands to it with both nRF UART and with the new Droidscript Puck plug-in on my Android phone. The other one flashes the RED Led on power up and will run through the self test ok, but I cannot pick it up via a Bluetooth scan or otherwise communicate with it. I have tried swapping the batteries over with no success. Are there any other tests or actions I can carry out?

  • Did you use it before and maybe flash something different? If yes, then remove the battery and press the button. Then put in the battery again and within 3 seconds release the button. Then it would omit any program you may have on the puck.

    Otherwise I would try re-installing the firmware. The procedure is documentation in the getting started.

  • Thanks for the reply. They are both out of the box unmodified, not flashed pucks. I tried following the instructions for re-installing the firmware but the puck doesn't show up in the nRF Connect application during a scan. It looks to me like the puck's bluetooth isn't working.

  • Okay, then I would also guess it has a problem...

  • Try putting the battery in with the button held down, then releasing it right away (the LED should stay red) - that'll put it into Bootloader mode.

    Does it appear via nRF connect as DfuTarg when you do that? Is so, maybe try updating the firmare on it?

  • I managed to update the working puck's firmware using that method. I couldn't see the troublesome puck using this method - I tried both nRF Connect and nRF Toolbox.

    Can I use the serial console to check the status of the Bluetooth?

  • Wow, ok - but the red light was lit all the time?

    If it was, but there's no bluetooth then I think you'd have to send it back and I'll send you another one out. Can you see any physical damage on the aerial?

    But yes, you could try and communicate with it via Serial (Ā­onsole) and could see if you can get it to scan for BLE devices with NRF.findDevices.

    If you can't get the bootloader working I'm not sure there's much that could be done with it though.

  • I'm pretty sure that the red led was on all the time. I'll try again tonight as I don't have the puck to hand right now.

    I'm not sure where the aerial is located on the board - is there a diagram you could point me to?

  • Thanks!

    The aerial is the thin white bar on the blue PCB, right near the edge of the board. I guess it could have got damaged if the Puck was re-assembled back to front - or it could have been a manufacturing thing but I'm very surprised they didn't pick it up.

  • OK, I'll take a look tonight and post pictures if I see anything that looks suspicious.

  • I can confirm that the red led was lit all the time when in bootloader mode. I still couldn't see it via nRF Connect.

    I failed to connect via the serial console on either board - due to my poor attempts at wiring and not wanting to make a mistake and damage the board(s).

    I couldn't see anything different between the working board and the bad board but have uploaded three files:

    1) good puck left - bad puck right.jpg.
    2) bad puck - side view.jpg
    3) bad puck - top view.jpg. (different lighting conditions).

    3 Attachments

    • bad puck - top view.jpg
    • bad puck - side view.jpg
    • good puck left - bad puck right.jpg
  • Thanks for checking so thoroughly - it sure looks fine.

    That is really strange. Maybe it's just a broken module? Please can you try one last thing - just swap the batteries between the two Pucks, in case it's a dodgy battery somehow.

    If it's still dead, send it back to me and I'll get another one out to you (please could you just stick a note in mentioning your username and the address you want the new one sent to?). If you still have the package it came in the address should be on there (and on the invoice), but if you don't have it drop me an e-mail and I'll send it.

  • Swapping the batteries was the first thing I tried. It didn't work.
    I'll try and get the puck posted to you tomorrow.

  • The puck is in the post. I appreciate that you're about to start your Christmas break so I will wait until January for the replacement.

    Thank you for your help.

  • Thanks! I'll get one out to you as soon as I get back

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Two pucks - one not working?

Posted by Avatar for user65682 @user65682