Odd connection behaviour ?

Posted on
  • Hi, I am having intermittent success getting mine to play nice at the moment.

    Booting with switch pressed - passes self test.
    Booting no switch - brief red flash.

    Using LightBlue Explorer .. I see the Puck advertise itself as Puck.js 5f19 but only briefly (few seconds) before it disappears. Consistent behaviour on reboot.

    WebBluetooth enabled on Chrome fine. I generally get "No Bluetooth devices found, Re-scan". If I re-scan and I am quick enough, I can then see the device, pair with it and connect successfully - and it works just fine. But the timing is pretty finnicky. I can miss the pair, or get the pair and miss the connect.

    Is this expected behaviour ?



    (p.s. fab device, as usual !)

  • In Chrome, I can sometimes get nothing detected on first pass. But a rescan finds them. I wonder if the Puck gets woken up or something. The Puck once found though is available to connect to, there doesn't seem to be a timing issue.

  • Hmm. Thanks!

    I think I have a different situation .. Once Chrome cannot see the Puck, that's it .. I have to pull the battery and try over again. Once I do get paired, and connected it's fine. But if I then disconnect (in the ide) and try to pair again, I get the "https://www.espruino.com wants to pair with:" and "No Bluetooth devices found. Re-scan."

    Hitting Re-scan will not find anything, unless I power-cycle the Puck, in which case the device appears almost immediately. If I hit "pair" quickly, it pairs and usually connects, but sometimes stalls on connect, in which case power-cycling usually sorts it ..


  • Could you make absolutely sure that LightBlue explorer is shut down - maybe turn bluetooth off on your phone?

    Basically Puck.js should boot up and start advertising all the time - but it stops as soon as something connects to it.

    With the nRF tools I've definitely had a situation where it seems like they auto-connect to the Puck, which then makes it impossible to connect with anything else until you force them to disconnect... it could be something like that?

  • Sigh. You are right of course. I had tried (and failed) to use an oldish Android phone to connect. And gave up. Then got it working on a little Android tablet .. but exhibiting the behaviour above. And actually the same behaviour in various BT tools on my iPhone.

    It turns out that the original, failed, old Android phone was still up to something. Presumably connecting.

    This is why the power-cycle/timing thing worked some of the time .. I was beating it (old phone) to connecting. Switching off old phone has cured problem !

    Sorry to waste everyones time !


  • Hey, not at all! I'll add it to the troubleshooting guide - I bet it's going to be a common problem :)

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Odd connection behaviour ?

Posted by Avatar for patmolloy @patmolloy