bootloader version for olimexino missing from download

Posted on
  • I am trying to upgrade my Maple r5 to the latest version of Espruino (v0.41) and the bootloader version "espruino_1v41_olimexino_bootloader_stm3­2.bin" is not in the zip available in the download section as stated in the instructions. Any idea where I can locate this, or has support for this method been discontinued?

  • Hi,

    I'm afraid Espruino is now too large to fit in flash alongside the bootloader so you'll have to overwrite it. All you need to do that is a USB-TTL converter though...­r

    hope that helps! I'll update the website.

  • Sweet! thanks for the answer. I tried to flash using the STM Flash Loader. It reported successful, but now I get no response on the serial port. Windows says it can't open the port. Any ideas?

  • I'm not sure I'm afraid - I was pretty sure that 1v41 worked ok on the Olimexino. You could try connecting to the USB-TTL port that you'd plugged in to flash (at 9600 baud) and see if anything happens when you reset the board without USB plugged in (Espruino uses USART1 if USB isn't in).

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

bootloader version for olimexino missing from download

Posted by Avatar for VirtualEnder @VirtualEnder