Cannot connect to ESP8266

Posted on
  • Dear forum,

    I've done a few things with the ESP8266 and Arduino IDE so far, but I'm far away from being an expert :D Especially all the booting and flashing stuff is a riddle to me

    And I thought, I might try Espruino, even though I'm pretty confused where and how the JS code is saved on the ESP without being newly flashed...

    But apparently, I'm far from getting it to work, because I cannot connect to my ESP after flashing.

    What I did:
    I tried with ESP-01 and ESP-12E. First, I erased the flash of both, then I flashed it as described here:­. After that, it says, I should be able to connect to via screen (ran on Ubuntu with sudo screen actually) to the ESP. I tried "sudo screen /dev/ttyUSB0 115200" and also with baud rates 57600 and 9600.
    I started out with the ESP-12E which I've never used before, but switched to the ESP-01, which I used few times already, so that I could make sure being in the correct mode.
    But the results are the same: On the console in screen I only see gibberish when I restart the ESP. It's kinda as if the baud is wrong or as if it's in boot mode again (what I can exclude with the ESP-01 though). And neither I can type in anything...

    PS: I tried flashing both sizes, 4M and 32M

    I'm sorry if this is a very basic problem, but I really tried to find an answer but yeah... no success...

    Thanks in advance

    OK, played a bit with the baud rates and suddenly got this message on baud 74880...
    Someone who can explain to me what I'm doing wrong here? :D

     ets Jan  8 2013,rst cause:2, boot mode:(3,7)
    load 0x40100000, len 1396, room 16 
    tail 4
    chksum 0x89
    load 0x3ffe8000, len 776, room 4 
    tail 4
    chksum 0xe8
    load 0x3ffe8308, len 540, room 4 
    tail 8
    chksum 0xc0
    csum 0xc0
    2nd boot version : 1.4(b1)
      SPI Speed      : 80MHz
      SPI Mode       : QIO
      SPI Flash Size & Map: 32Mbit(512KB+512KB)
    jump to run user1 @ 1000
    error magic!
    backup boot failed.
    user code done
  • How did you erase the flash?
    What build of Espruino did you try to flash?
    Do you have the Espruino Chrome IDE? Can you connect or use console (left pane) there @ baud 115200, using that?

  • That's stage 1 bootloader saying that flash doesn't contain a valid image. So you didn't flash correctly.

  • ...yep, baud rate around 74800 got me connected from a pico to a ESP8266 ESP-09... I decided not to flash until I can positively communicate with the ESP8266. I did already flash successfully with ESP8266 images ESP-01s, but not with Espruino images yet. Even though the ESP8266 can do some things when flashed with Espruino, I do snot see it very powerful to do both: handle Wifi AND application. The Espruino 'inner loop/dealing with the hardware' competes with the duty to properly and timely handle the Wifi events. Therefore, I'm still sticking - successfully - with an original / PICO Espruino board and ESP8266 as a Wifi slave...

  • Hey guys,

    thanks a lot. Obviously I used the wrong image. I followed the instructions of the youtuber called "ACROBOTIC" and it might be outdated or I understood something wrong. It actually said ESP8266 for the files, but I didn't use the combined one.

    Anyways, I now flashed as described in the post of Gordon here:­279176/?offset=25 and I can get it working.



  • Hey,

    I'm sorry for bothering you again, but I still can't get it to work properly. When the system is newly flashed, I can use the Web IDE to play around with it. But as soon as I've flashed one single JS script and then reset the ESP (disconnecting from power and powering on again) I cannot reconnect to it anymore.

    I only get


    I'm using v86 for the ESP and need to reflash it every time to gain access to it again...

    Thank you,


  • I've flashed one single JS script

    You mean: '...uploaded from IDE...?

  • uhmmm yeah sorry :D forgot that flashing is something else. If it's important, I'm using the Chrome app on Windows.

  • Are you saving the script, and having it load on board reboot? Depending on what you are loading that could lock you out. Maybe post the script you're sending over the IDE

  • Well, i just used the standard JS-Script you get when you start the IDE. Even though I can't connect to it via IDE, I actually can connect with putty for example and type in commands...

    And I can even connect via WiFi. Well I guess that should work too :)

    I have some things about it the ESP now, but the flashing and saving stuff is still a riddle to me.. When I submit my real script to it, then it's actually written to the flash and available after reboots of the ESP right? But I can also instantiate variables and create functions the command line. Is there a way to save them too? I've read about, which seems to do sth like that. But is the initial script overwritten then?


  • Have you made certain IDE is set to 115200?

  • Ooops, bad timing... But yeah, it is definitely set. But I think I'll stick to the WiFi-Connection. And if I'm lost, I'll just reflash the image.

    Thanks a lot

  • If you can connect and upload over Wifi that's good. Odd that you have problems over serial. I haven't experienced it that way round. is for setting up your wifi connection and storing so the board will join your network (or say act as an AP) when booted. For saving other programs it's save(). It won't be stored unless you save it.

    Check out E.on("init",...) if you want that code to run when your board is restarted.

    You should also check out this page

    One final thing. If you're new to Espruino, you'll make better progress if you get a Pico or original Espruino. It will work out the box - and speed you up the curve. Plus you can test code on there before you move it to ESP8266.

  • Connected


    I've had this issue with Windows 10. Even a reset on the board does not fix- it's to do with the USB to serial... If you unplug the USB and plug it in again - all will be fine.

    It occurs after flashing....

    As you have discovered, via wifi works well - it is about 4x faster than serial too.

  • ahhh ok thanks a lot. Didn't try that of course -.- :D
    Anyways, it seems to work great, even though I'm still having problems with wifi.connect for example, the callback doesn't seem to be called when there was an error while connecting. But apart from that it works really nice, great stuff you did here, thanks a lot for Espruino :)

  • @Wilberforce: 4x faster? I must have something configured wrong. I find that the console is slower and sometimes delays responses to typing etc. over wifi. It can be very annoying to be typing and have a pause for a second (or a few) before the characters your typed print out in the console and "catch up" to your typing.

    Doesn't happen with the serial connection. 115200 is very fast.

    Something I haven't configured properly for wifi? I hope?

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Cannot connect to ESP8266

Posted by Avatar for Timothy3001 @Timothy3001