• Driver worked well in Win 7 until I updated to Win 10. I didn't do a clean install of Windows 10, just an upgrade from 7 to 10. Plugged in a fresh Pico and saw the red light flash. I opened up the web IDE tried the normal way to connect and it said Connect failed. I tried a restart but same thing. So I checked Device manager and noticed:

    1 Attachment

    • Device Manager.png
  • Have you tried just re-installing the drivers? I know people are using it with Windows 10 and don't have problems, so maybe the drivers got disabled in the upgrade process?

  • @Gordon Strange, everything seems to be functioning correctly now. My USB cable is most likely not functioning properly.

  • @Gordon I spoke to soon. I switch cables and USB ports and I am still having the same issue. This will also be my second time reinstalling the drivers.

    Oops I forgot one crucial step: Unzip the file, run the executable, and then go to C:\Program Files (x86)\STMicroelectronics\Software\Virtua­l comport driver in Windows Explorer and double-click either dpinst_amd64.exe for 64 bit systems, or dpinst_x86.exe for 32 bit.

    Everything appears to be functioning properly again :-)

  • Great! glad you got it sorted - the drivers are pretty strange like that... I'm tempted to just distribute them outside the ZIP file :)

  • Красавчик! е*ался при настройке на виндовс xp, по финалу взлетело. Зашел в папку с установленным драйвером и дважды клацнул C:\Program Files\STMicroelectronics\Software\Virtua­l COM Port Driver\dpinst_x86

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Driver issue(Win 10): STM32 Virtual ComPort in FS Mode

Posted by Avatar for d0773d @d0773d