Connection Problem

Posted on
  • Hi All,
    I have successfully flashed the latest version (1v85) of Espruino and result can be found below. However; I can not connect to my nodeMCU either using Espruino Web IDE or with this command "screen /dev/ttyUSB0 115200".
    When I try screen command I seen no error it just says "[screen is terminating]".

    Does anyone have an idea what might be a problem? v1.2-dev
    Running Cesanta flasher stub...
    Flash params set to 0x004f
    Writing 4096 @ 0x0... 4096 (100 %)
    Wrote 4096 bytes at 0x0 in 0.4 seconds (90.3 kbit/s)...
    Writing 462848 @ 0x1000... 462848 (100 %)
    Wrote 462848 bytes at 0x1000 in 40.1 seconds (92.3 kbit/s)...
    Writing 4096 @ 0x3fc000... 4096 (100 %)
    Wrote 4096 bytes at 0x3fc000 in 0.4 seconds (90.5 kbit/s)...
    Writing 4096 @ 0x3fe000... 4096 (100 %)
    Wrote 4096 bytes at 0x3fe000 in 0.4 seconds (90.5 kbit/s)...
  • Disconnect usb and plug it in again then from the web ide set the serial speed to 115200 and connect.

  • I have already done what you said couple of times but still IDE shows me an error saying "connection failed!"

  • Try to connect with 57600, which is the default baudrate for first steps in Espruino.
    At least you should see 2 lines with rst.....
    Anyway, I had a problem flashing actual version on my ESP-01.
    Going back for about a month, I found a running version (.76?)
    Actual I create my own firmware without crypto (or without graphics) and that works fine.

  • I tried the baud rate 57600 unfortunately with no success :( In the meantime; I played with arduino IDE and everything is working. I do not really understand why I can't get Espruino worked, which is a little bit discouraging...
    BTW; when I try to connect, web IDE is giving the following messages. Does it ring a bell?

    >>> Connecting...
    Set Slow Write = true
    Unable to open device (connectionInfo=undefined)
    ERROR: Unable to open device (connectionInfo=undefined)
    >>> Connection Failed.

    Update :
    I have solved my problem. It seems Web IDE needs some special authorizations when it is working under linux. I can't still make it connect to the port but it works via TCP port. I followed the tutorial here .

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Connection Problem

Posted by Avatar for Filip @Filip