SPI is busted on ESP8266?

Posted on
  • It sure seems to be at least. Has anyone else had any success?

    Using d8dec28 build ( http://forum.espruino.com/conversations/­279176/#comment12701347 ) and I can't get SPI1, or an SPI object created with SPI() to actually transfer data over SPI.

    Much more detail in github:

  • No direct experience of SPI but commented on the issue. Setting pinMode was critical in some stuff I was doing. In your code you are referencing the pin (in the pinMode argument) as numeric '13' versus 'D13'. I referenced with the letter prefix.

  • Thanks, it wasn't that (I'd tried it both ways last night too)

  • Not sure - all I'd say is make sure you power cycle it after trying hardware SPI. It could be it messes the pin state up and doesn't fix it properly.

    Also, have you tried different pins? could be hardware SPI blocks it somehow. Maybe just choose 2 random pins and short MISO and MOSI - it should then echo back any data you send.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

SPI is busted on ESP8266?

Posted by Avatar for DrAzzy @DrAzzy