Constant reboot after flashing with Espruino

Posted on
  • Hello,

    I got a NodeMCU 1.0 that seems to work fine with both the AT and NodeMCU firmware when connected to my PC, but after I flash it with Espruino, most of the times it goes into an infinite cicle of reboots.

    This is what I get, over and over again:

    ets Jan  8 2013,rst cause:4, boot mode:(3,6)
    wdt reset
    load 0x40100000, len 1396, room 16 
    tail 4
    chksum 0x89
    load 0x3ffe8000, len 776, room 4 
    tail 4
    chksum 0xe8
    load 0x3ffe8308, len 540, room 4 
    tail 8
    chksum 0xc0
    csum 0xc0
    2nd boot version : 1.4(b1)
      SPI Speed      : 80MHz
      SPI Mode       : DIO
      SPI Flash Size & Map: 32Mbit(512KB+512KB)
    jump to run user1 @ 1000
     _____                 _ 
    |   __|___ ___ ___ _ _|_|___ ___ 
    |   __|_ -| . |  _| | | |   | . |
    |_____|___|  _|_| |___|_|_|_|___|
     1v83 Copyright 2015 G.Williams
    WARNING: the esp8266 port is in beta, don't expect everything to work
    Flash map 4MB:512/512, manuf 0xe0 chip 0x4016

    I flashed it with --port /dev/ttyUSB0 write_flash -fm dio -ff 80m -fs 32m  0x01000 espruino_esp8266_user1.bin

    Any ideas?

  • Same thing.
    Is it possible to have power problems when using the NodeMCU on USB?
    If it works with AT firmware, it it possible for it to be reseting because of power?

  • I've a NodeMCU and its running with its own power supply.
    First when I got it, I tried with USB, and ran into tons of problems.
    Sometimes it worked, sometimes there was no way to get it running.
    I would recommend a seperate power supply. May be adding a big capacitor could help (?)

  • Also.... do you have the command line you used to flash it?

  • Ah, I've encountered what may be the same situation. Turns out there's a bug in the Espressif SDK that Espruino hits sometimes when restoring wifi settings. I think I have a work-around :-).

    Update: new build available, please see­621/

  • Just on the power thing, I've been running from USB via a USART adapter with a 100uF capacitor soldered between the VCC and GND (ESP8266-01) and have no issues - even when running a DS18B20 and 433Mhz radio from the same adapter. Nice big capacitor seems to be key - and I've read mounting as close to the ESP8266 as possible, is also a good idea

  • Looks like sometimes it works and stays up, sometimes it doesn't. It must be some hardware problem, probably the power, but I don't have a way to power it besides the USB for now.

    Thanks everyone for the help.

  • Did you try the new build?

  • Yes, same behaviour, so it must not be related to the build.

  • I struggled with this for quite a while.

    You will need a separate power 3.3V power supply. The usb is not sufficient nor stable enough to power the ESP8266 while in operation. I would suggest you also use a 100uF capacitor or greater close to the power pins of the chip.

    One other problem I encountered was not setting both the CH_PD and RST pins to high via a pull up resistor. It would not operate properly for me otherwise. Goodluck

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Constant reboot after flashing with Espruino

Posted by Avatar for user59750 @user59750