Is the hosted compiler working?

Posted on
  • I have only stated writing code for my Espruino Pico in the past 2 days.
    When I add the


    directive to my code and try to "Send to Espruino" I get a red error popup in the bottom right-hand corner of the code panel that reads: "Error contacting server. Unable to compile code right now."

    Is this a known issue, or am I doing something wrong?

  • No, sorry, you're not doing anything wrong.

    I just restarted it an it should be fine now - there was a power outage at my web hosts and it looks like when the server came back up, there was some strange configuration issue.

  • Thanks, I'll try it out tonight.
    If compiling doesn't solve my timing issues, I'll be back with some questions for you over in the Interface forum.

  • Hi Gordon, I know you've signed off for Christmas: so Merry Christmas.

    But it appears the online compiler is 'offline' again if you have the chance to restart it.


  • Hi - bad timing I'm afraid... My hosts had to physically move the server which meant powering it off, and when it came back on the compiler didn't come back up in the right state... The compiler was off for maybe 12 hours before I fixed it :)

  • I'm afraid it's offline again. Or does it even still work?

  • Still can't get up and running any news on this

  • @Stipser all your posts so far have been about ESP8266... are you trying to use that? The compiler only works for STM32 Espruino boards, so that could be your problem?

    @BillHoy I tried this just now and it works great for me. Which board are you trying to use? What code are you using and what error messages are you getting?

  • Gordon, using original Pico, Espruino Board, Puck, Espruino Wifi all "originals". When I press Icon to start as I have always done, I only see a white screen, blue top border and "Espruino Web IDE" and that is it. This has never happened before. I had just purchased your book and wanted to study this and work thru the examples. So this problem was/is frustrating.

  • Strange! Works on Tablet

  • Oh - so you're not able to even use the IDE?

    Could you post up a screenshot? How are you running the IDE - as a Chrome Web App, from, or using the Windows Installer?

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Is the hosted compiler working?

Posted by Avatar for Snerkle @Snerkle