[SOLVED] win 10 ?

Posted on
  • Hello

    Has anyone successfull used the pico with windows 10 ? The recomanded ST32 driver does not work for me. Maye it is not win10 compatible ?



  • According to Microsoft, in Win 10 any USB CDC devices should 'just work' without drivers. I guess that's not actually the case then?

    In the device manager, what does it say next to the STM32 device?

  • My son upgraded from 8.1 to 10. No driver (re)install, everything is fine.

  • Upgraded from 8.1 to 10 64-bit.
    Connected pico, and able to connect on com3, the version 1v79.
    Upgraded to 1v80 and connected com3.

  • Win10 64 bit. Lenovo Yoga 3 Pro. Driver error. see screenshot. Installed driver http://www.st.com/web/en/catalog/tools/P­F257938. Same error.

    1 Attachment

    • STM32.png
  • Hum, it's working fine for me on Win10.

    I mean, the computer itself has all sorts of problems it's never had before...

    But Espruino is working fine. I may have had to reinstall the driver (I did, it didn't work, and then I plugged the Espruino into a winxp box and it did the same thing - it was the save bug, so I reflashed firmware and it worked. )

  • Thx all for the answer. I've connected an original epruino board. It works !
    Tried several picos. No luck. I'm going to test it with a different computer with win8.1.

  • Upgraded the pico on a win8.1 station to espruino 1.80.

    Now my win10 notebook has no problem. detecting it.

  • Ok, thanks for the update! Please can some of you give this a try and confirm it? That a Pico with an older firmware doesn't work, but it does work with new 1v80 firmware?

    Also, I assume that the firmware update mode also doesn't work in Win 10? If so, the board firmware will need updating with DFU (or as @DrAzzy had suggested before, I might have to do some JavaScript that'll update the bootloader via JavaScript)

  • Windows 10 working perfectly here. I had to install the ST VCP drivers (v1.3.1) but, since then, both normal operation and firmware update work fine. I wonder if v1.4.0 of the driver is to blame? I have some recollection of having to use the older version on Windows 8.1 too.

  • Yes the firmware update mode also doesn't worked for me on win10.

  • I'm having this issue too, I don't currently have access to a non Win 10 machine. I've just got my pico in the mail so it kinda sucks that I can't do anything with it yet. Am I correct to assume that I just need to update the firmware from a different device to get it to work?

  • Currently using a Windows 10 64 bit machine with a Pico running 80. No issues to report.

    I've attached the working driver here.

    4 Attachments

  • Woops, seems I forgot to install the driver that was linked in the quick start! Terribly sorry about that. Seems to be working properly now.

  • Ok, great!

    Shame that Windows 10 still needs drivers though. There was a Microsoft knowledgebase article saying it didn't :(

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

[SOLVED] win 10 ?

Posted by Avatar for Sacha @Sacha