• Hi, Gordon, hi All!
    After dodwnloading some code like A#.write(1); B#.write(1) etc. , I've checked that It works.
    then I put reset(); command, and the board stoped and couldn't connect again. But trying to reload the board thru the ST-Link utility i see only "couldn't connect to target" and recomendation from this forum to download thru the "press and hold the reset button of the board and choose the Menu item "Target" -> "Connect" (or click on the connect icon). Release the reset button." doesn't work even after tens of attempts.. ouhhh, did I kill It ???

    Update: I connected thru the terminal, and now the log looks like =undefined

    Erasing Flash.....
    Programming 3810 Bytes.......
    There were 246 errors!

    Whath the errors? how can I reset the board?

  • I'm terrible sorry, for my previous topic, I just forgot to set jumpers CN3, responsible for swd programmer mode.
    Sorry again.

  • I'm having problems saving using the same board.

    Erasing Flash.....
    Programming 3810 Bytes.......
    There were 86 errors!

    I tried removing the CN3 jumpers but I still get the errors. How did you fix this?

  • Hi, I didn't. Try to use Ver1.44 https://espruino-nightly.noda.se/2013-12­-13/stm32vldiscovery/
    but It didn't help me. I asked Gordon about It once again: http://forum.espruino.com/conversations/­334/#comment3774

  • Hi,

    Looks like there is some issue with the save to flash functionality on the VL board - I'll try to take a look today but I'm really busy right now.

    If anyone wants to take a look it might be that 'gen/platform_config.h' has the wrong details in it for where to flash the data (or maybe just what the page size is).

  • I don't know what I am doing but I will take a look and see if I can figure it out if you like.

    I was trying to find platform_config.h for the VL but the only one I can find is in '/targets/arduino'.
    '\gen' directory is empty.

  • Hi,

    The platform_config.h file is auto-generated using: scripts/build_platform_config.py (so you'd have to modify that)

    I could be pretty sure that's the problem as the flash page size is 2048, and I thought it was 1024 on those parts. I'll give it a try later...

  • Yes, that's what it was. I've just committed the changes, so if you wait until tomorrow, the espruino-nightly for STM32VL will support saving properly

  • Thanks for fixing so quickly. I did have a quick look but I'm too stupid to know what to do...

  • I picked up the latest nightly build from (https://espruino-nightly.noda.se/) this morning and I can confirm the changes made work and that there are no errors when saving programs on the STM32VL DISCOVERY board.

  • Great! Thanks for letting me know!

  • Dear StuntMonkeh, could you please help and repeat the code snippet from this topic with onInit function: http://forum.espruino.com/conversations/­334/#comment3836 thanks!

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

I can not connect to STM32VLDISCOVERY after some experiments

Posted by Avatar for Andrey @Andrey