Connect STM32F4Discovery to Windows 8 Computer

Posted on
  • Waiting for my espruinos I decided to start with STM32F4Discovery.
    Everything worked fine up to the point, where I tried to connect to Espruino itself.
    Installation of ST-Link and flashing of the software worked fine.
    See images of steps:


    Now I reached the point to enter first command but I don't get a connection.
    Last step was to connect the board via cn1 to power and via cn5 to my computer.
    I tried a lot of other options, but result always was the same, nothing.
    Internet is full of instructions but right now I am more confused than ever before.

    Hopefully there is somebody helping me.

  • Hello,
    do you have installed the ST-Link USB-Driver? If your board is connected to the USB a virtual com port is created. It appears in the windows device manager under "Ports (COM & LPT)" as "STMicroelectronics Virtual COM Port (COMXX)" where XX is the sequence number.

    You can find find the drivers here.

  • Hi,

    When you press and release the reset button on your board, does one of the LEDs right by it flash for a fraction of a second? That would show that Espruino is installed on the board and working...

    Also, it's worth leaving the board plugged in for maybe 15 minutes. While the process is automatic, Windows 7 (at least) takes a long time to install the drivers it needs.

  • Thanks tickTock and Gordon,
    @tickTock, drivers are installed now, but result is the same, there is no Ports (COM & LPT) folder on my Windows 8(64 bit) PC in device manager. Chrome application does not show any port.
    I tried the same on my 2nd computer (Windows 7, 32 bit). There the Ports-folder is available, showing 2 bluetoth ports (com4/com5) only. Chrome application shows com3/com4/com5, none of them works.
    @Gordon, the Led (ld4?) flashes very shortly. I could install the sample application without problems, so ST-Link and flashing works. Waiting for up to 30 minutes didn't change anything.
    BTW, cn1 is connected to power, cn5 is connected to PC, power LED is on, Com LED flashes red and cn5 LED is on.
    If only cn1 is connected to PC, power is on, Com is on. After connecting ST-Link, com LED flashes red/green.
    For testing I take 1v39, some tests with other version from nightly build gave same problems.
    Regards from Krefeld(Germany, about 18 degrees Celsius and sunshine)

  • Hi Jurgen,

    That's strange - so it looks like Espruino itself is starting up (because of the brief LED flash).

    Does windows react in any way when you connect CN5 (eg. a 'connection' sound)? Does 'LD7' (by CN5) light up?

  • Hello Gordon,
    good news first, it works.
    @ Gordon LD7 lighted up all the time.
    Thanks to your and tickTock's help most possible problems could be checked.
    So at the end there was only one thing left, I took a new USB-cable out of my box and thats it. Should have done this before, its always the unexpected.
    Espruino Web IDE found the port and first test with LED blinking is working.
    Thanks for your help and sorry for wasting the time.

  • No problem - glad to see you got it working!

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Connect STM32F4Discovery to Windows 8 Computer

Posted by Avatar for JumJum @JumJum