WEB-IDE new-bee question

Posted on
of 2
/ 2
  • Under windows 8.1 / using Chrome saving a file from the Web-IDE produces a
    generic java script file in the download files directory.

    Is there a preference to change this generic file name and the directory in which it is downloaded? I would like to keep a special java script backup folder with user friendly file names. Using a "save as" file under download would be helpful.

  • Strange... do you not get a 'save as' dialog? Whenever I've tried that's what I get - but then I haven't tried on 8.1 I guess...

    Anyone else have this problem?

  • do you not get a 'save as' dialog?

    NO, it generates sequential file(s) with the format "code(x).js" on the bottom
    download task bar it generated, on using the save command, from the WEB-IDE
    and does not allow "save as". I was hoping to have organized "Arduino like" folder(s) for all my Espruino projects.
    Windows 8.1/x64 Chrome 35.0.1916.114m

    Note: The only options, in the folder dropdown box arrow is ...
    "open files of this type"
    "show in folder"

  • Ok, thanks. I'll see if I can fix this - on every other OS I've tried you get a save as dialog...

    Are you using anything non-standard (like a Chrome beta version) that might be causing it, or is it a totally normal Windows install?

  • Are you using anything non-standard (like a Chrome beta version) that might be causing it, or is it a totally normal Windows install?

    Just the normal Chrome (non-beta) install. For windows, I upgraded from the standard
    widows 7 to 8.1 on this new laptop computer.

    Windows 8.1/x64 Chrome 35.0.1916.114m

  • I can confirm that I'm having this same issue on Windows 8.1 - 64 bit.

    1. Its a normal Desktop install, and this computer has only had Win8 &
      8.1 on it.
    2. It's the latest up-to-date, normal Chrome Version 35.0.1916.153 m.
    3. Chrome is running in "Desktop mode"
    4. The new Win8 UI is completely hidden on this machine.

    I'm happy to help you test this; ping me if I can help.


  • The same on Debian in both modes "code" and "Graphical Designer"

  • Hi - can you all try downloading the Web IDE from GitHub? Instructions here: http://github.com/espruino/EspruinoWebID­E

    Hopefully I've just fixed this (but I can't test it here so can't be sure). If you can confirm it works then I'll roll it out in the Chrome Web Store though.

  • It works here on Ubuntu 14.04lts 64bit.
    Another thing is the 3 buttoms to close and minimize and.. , is it Chrome that have changed the position. At the beginning it was to the left, as is normal in Ubuntu, but now they are to the right, as the only program on Ubuntu.

  • @Frida: that one is the new Web IDE. It makes its own title bar (so it can put notifications in it), but it doesn't know exactly what the OS+Theme is (for instance I run on Ubuntu and I have my icons in the same places as the Web IDE).

  • I can confirm this fixed it on my Win 8.1 system on Chrome Version 35.0.1916.153 m. Thank you sir.


  • Great, thanks for letting me know!

  • Note: The Web-IDE version did not change - still is v 44 <-----????
    The save-as works but you have to put in place of "code" --> "codexxx.js" extension. (".js")
    There is no file type selection - it's lockout.

    Windows 8.1 64 Bit
    Chrome 35.0.1916.153 m (no beta)
    Espruino 1v65
    Web-IDE v 44
    Board: Espruino

  • my comment was based on the dev IDE from github, as he linked above. i'm not sure is the 'fix' got rolled into the Chrome Web store and/or if the changes have been approved by Google yet.

    If you really need the update, you can always install the dev version.

  • I got the Web-IDE from Github.

  • My mistake, i just re-read your questions/comments and you are correct. I apologize, as I didn't even notice the drop-down thing, as I was just happy that the save-as box popped up at all.

    Yes, the IDE number on the Dev/github version IS the same as the release version. But, i'm not sure if release has been updated or not.

    And Yes, the 'save as type' drop-down is fixed as 'all files', but the default filename should end in .js (at least)

    Sorry & sorry that I couldn't help ya.

  • In chrome://extensions/ you should be able to see the version number - it should be v45 (not v44). It might be you somehow managed to download an older version from GitHub, or you had a version that you downloaded previously?

    Can anyone else confirm about the .js extension not appearing by default? It seems to work fine for me.

  • Just reproduced this on Mac. I'll see what I can do

  • I pulled it again and it now says v45. The previous v44 had the "save as" fix already in the Github pull.???? Now the only nickpic is the file extension not
    defaulting the "js" and not being able to change the type of file. I can live with putting in, for each "save as" file ".js" but for some it is a hassel.

    It seems to work fine for me.

    Do you have Windows 8.1?

    Windows 8.1 64 Bit
    Chrome 35.0.1916.153 m (no beta)
    Espruino 1v65
    Web-IDE v 45
    Board: Espruino

  • On linux it works fine - but as I said a few minutes later, I reproduced it on Mac.

  • Are you sure it's not just that 'hide extensions' was on? This was the case on Mac.

    Clicking 'save' still saved a file called 'code.js'.

  • I'm on Windows 8.1, Chrome Version 35.0.1916.153 m, and just pulled the latest Web IDE from Github (which now shows 0.45)

    The file-save dialog defaults the filename to code.js

  • Have you turned on 'show extensions' in the settings? I don't have Win 8.1 here but every version of windows I've seen including 7 has that option.

    I guess if it's on you may see code.js and if it's off you may just see code.

  • dis-reguard - extension js still not working but that's not a big issue.
    If the file does not have the js extension, when "saved as" it creates a normal file.
    Since, in my case, I selected a document file folder which only holds files created
    from Espruino then all I do is rename with the extension "js"

  • I'm glad you found a process that works for you @user7114 - (wow that username feels very dystopian )

    Windows does have a default setting that hides file extensions by default, as @Gordon mentioned. This may be what's causing the difference in what you're seeing.

    This is one of the first options that I change when using a computer, so I didn't even think of it.

    The setting is buried in Windows 8, but I'll try to describe where its at if you want to see how your computer is set and/or change it.

    • Open control panel,
    • If view-by is set to categories, change it to large icons
    • Within control panel, select the Folder Options icon
    • Within the Folder Options dialog box, choose the 2nd tab titled view
    • go to the bottom section labeled Advanced settings
    • UNCHECK the option entitled Hide extensions for known file types
    • click apply then ok (or just ok) to close the dialog box

    You should now see the file extensions of all of the files when viewing a directory on your computer. (The extensions were always there, Windows was just being helpful and hiding them for you.)

    I hope this helps.


  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

WEB-IDE new-bee question

Posted by Avatar for user7114 @user7114