You are reading a single comment by @DrAzzy and its replies. Click here to read the full conversation.
  • I'm trying to build the Espruino on Linux...

    I've installed the codesourcery compiler, and I can run:

    ESPRUINO_1V3=1 make

    And I get a deluge of warnings. But at the end, it checks the size, and gives pass/fail depending on the compiler flags I use, and I get my .bin file.

    So everything's grand right?

    I pull the .bin file down from the linux system via SCP, put it in the root of my local webserver.

    I use the webIDE to flash it (pointed at­1r3.bin ). Flash goes normally and reports success.

    Then I press reset, and the blue and red LEDs stay on at about half brightness, and nothing else happens. Computer does not detect USB device. I can get it back into bootloader mode by mashing reset and btn1, and flash a working firmware to it, so that's not a problem.... but I'd like to be able to build Espruino firmwares myself.

    What am I doing wrong?

    I've tried with O3 and Os flags, and either way gives same result. This is using the code obtained via git clone­ - only thing I've changed is CCPREFIX in the makefile...


Avatar for DrAzzy @DrAzzy started