You are reading a single comment by @user156427 and its replies. Click here to read the full conversation.
  • Hi,
    I later tried going with the Github method you suggested but encountered a snag when trying to 'Flash from file'. There is probably something super obvious I'm missing as I don't really know my way around Github. These are the steps I followed (see attached images):

    I tried uploading the .zip artefact file entitled to the IDE. I also tried unzipping and re-zipping it.

    I noticed a downloaded .zip of v20 from is 520kb but the (from GitHub) is 318kb but if I unzip it I get a folder called espruino_2v20.70_banglejs2 which is 514kb and if I compress that it again (with the same folder title + .zip) it is still 318kb. You can see the folder has the relevant .bin .dat .json files and the manifest.json reads:

    "manifest": {
        "application": {
            "bin_file": "espruino_2v20.70_banglejs2_app.bin",
            "dat_file": "espruino_2v20.70_banglejs2_app.dat"


    I'm on a Mac if that makes a difference.

    5 Attachments

    • a.png
    • b.png
    • c.png
    • d.png
    • e.png

Avatar for user156427 @user156427 started