You are reading a single comment by @adjtm and its replies. Click here to read the full conversation.
  • This is the app repo at . I'm not yet to the point of connecting to the IDE. I need to get the firmware up to date on the watch before I'll even consider putting a custom watch face on it.

    There's no issue with the computer Bluetooth. It's a laptop with wifi built in. Device manager shows all the necessary devices, all claim to be working correctly, and driver update tells me the best drivers are already installed.

    And if you note in the last paragraph of my message

    1) my phone can see both the computer and the Bangle.js when I have it scan for Bluetooth devices, proving that Bluetooth is working on the computer.

    2) The computer does pair with and connect to the Bangle.js, becayuse the popup says "paired", and the button shows "Disconnect" which kinda implies we've got a connection.

    It's just that the actual firmware upload fails. 

    -- LATER --

    Doing a little research, it looks like BLE support on the laptop may be a bit dodgy. I tried browsing to the app loader on my smartphone and got a bit further. I got it connected, and the hamburger in the Firmware Update now reports I'm on 2.18, and that 2.19 is available.

    Update is in progress now, we'll see how this goes. Thinking ahead, this seems to indicate that I'll have to use my phone to upload apps to the watch. This will be a bit of a pain vs direct upload from the IDE, but any port in a storm, I guess.

    -- EVEN LATER --

    Yeah, it definitely looks like BLE is pooched on the laptop. I tried it again on the laptop this time from within the IDE. Similar result to App Loader: it sees the Bangle.js claims it's paired, but then hangs at "Connecting".

  • However nothing I could do would actually make the upload happen. I may be a bit stupid here, but why isn't there a big friendly "UPLOAD" button on the page?

    From memory, I think that you have to touch the version you want to upload (the development version is at the end). Then an UPLOAD button appears at the end, you touch it and the upload starts. Yes, maybe not very intuitive. I hope this works for you.

  • Yeah. I got that when I tried it on the phone. The laptop never even got to the point of showing me the available versions to upload. So I'd guess that you're correct that BLE is broken. Which is kinda a surprise, since it's a builtin Bluetooth chip, not a USB dongle, which supposedly has BLE. At least it can see the watch and pair with it. it just can't actually talk once it's connected.


Avatar for adjtm @adjtm started