You are reading a single comment by @Lorenzo and its replies. Click here to read the full conversation.
  • Hi all, I'm also struggling using the GPS. Last week I was able to get a GPS Fix (don't know the correct terminology) after 40 minutes of waiting. Then I had to restart the watch and, trying again, GPS Fix didn't work. I tried again yesterday. Another ~40 minutes and got it working. Stopped the GPS Info app, started it again, and after a few seconds GPS Fix was working again.

    Yesterday night I tried again, no luck. Waited more that 20 min, than had to go back inside.

    Evey time I try I update fresh AGPS data.

    This morning I got the watch outside, after 20 minutes I connected the IDE and Bangle.on('GPS',print);Bangle.setGPSPowe­r(1) continues to give me a series of

    { "lat": NaN, "lon": NaN, "alt": NaN, "speed": NaN,
      "course": NaN,
      "time": Date: Tue Sep 5 2023 11:05:14 GMT+0200,
      "satellites": 0, "fix": 0, "hdop": 25.5 }
    

    The GPS Info app reports:

    in view GP/BD/GL: 0 4 4
    

    But still zero satellites used.

    The watch is still outside, I'm going to let it drain with GPS Info app opened. I hope this fixes it.

About

Avatar for Lorenzo @Lorenzo started