You are reading a single comment by @rigrig and its replies. Click here to read the full conversation.
  • Oh wow it definitely feels much faster now and I love your new slopeclock! Looks really really great and the animation is really smooth :D

    Nevertheless, I think I found one little issue -- but I'm not 100% sure if its the settings app or the firmware update: I can no more open the LCD settings -- I already tried to re-write the settings, I tried an older settings version (0.49) and I removed the setting.json file completely, but I always get the following error (read via Web IDE):

    Uncaught Error: Cannot read property 'wakeOnBTN1' of undefined
     at line 29 col 630 in
    in function "showLCDMenu" called from line 14 col 127 in
    in function "b" called from line 1 col 79
    ...if("function"==typeof b)b(l);else if("object"==typeof b)if("...
    in function "select" called from line 1 col 52
    in function "p" called from line 1 col 17
    in function called from system

    Update1: I also downloaded the setting.json file if it helps as it seems that some props are missing in my settings.json file.
    Update2: If I manually upload the "settings.min.js" file from the setting github repo everything works fine again. So not sure if only my Bangle was corrupted but I found it a bit strange that rewrite settings did not help...

  • I had the same issue a while ago (missing property from settings.json), at the time I figured I just messed it up myself somehow, but maybe there's a bug somewhere?


Avatar for rigrig @rigrig started