• Well I just tried updating the firmware again and got the same result. BTW, I noticed that the instructions on the Bangle.js "Firmware Updates" page say to release BTN1 a moment after BTN2 when holding down both to enter DFU mode but the IDE Flasher instructions say to release both buttons at the same time. In any case, I reverted back to 2v13 again and it worked as expected so it doesn't seem like a button issue.

    A relevant difference, perhaps: After installation of the 2v13 firmware completes my Bangle automatically restarts and shows my default watchface. But after installation of 2v14 completes I see "Reloading..." centered on the screen with "-->Bluetooth" on the bottom. I waited about a minute and nothing happened so then I long-pressed BTN3 and the "Loading..." box appeared but my watch never restarted. So I ended up long pressing BTN1 and BTN2 to restart the watch and that leads to the logo screen with "-->Bluetooth" on the bottom as I explained earlier.


Avatar for TTBangler @TTBangler started