• Hello Community,
    I am totally new to this community. I am facing a issue which may be really common issue.
    I flashed my Heltec Esp32 Automation kit with "espruino_esp32.bin" Upon flasing I saw below console message.

    esptool.py v3.2
    Serial port /dev/ttyUSB0
    Chip is ESP32-D0WDQ6 (revision 1)
    Features: WiFi, BT, Dual Core, 240MHz, VRef calibration in efuse, Coding Scheme None
    Crystal is 40MHz
    MAC: 3c:71:bf:ff:11:f0
    Uploading stub...
    Running stub...
    Stub running...
    Configuring flash size...
    Flash will be erased from 0x00001000 to 0x00114fff...
    Compressed 1128672 bytes to 742852...
    Wrote 1128672 bytes (742852 compressed) at 0x00001000 in 65.9 seconds (effective 137.1 kbit/s)...
    Hash of data verified.
    Hard resetting via RTS pin...```
    Which according to documents looks normal.
    But then when I tried to connect the board with 
    "espruino" command I am getting the following error same error I am getting while connecting to web IDE  below is the error. 

    Using first port, {"path":"/dev/ttyUSB0","usb":[10,null],"­description":"Silicon Labs"}
    Connecting to '/dev/ttyUSB0'
    No result found for "process.env" - just got ""
    Unable to retrieve board information.
    Connection Error?

    I am using Heltec Automation WiFi Kit 32 V2 and attached is the bin file I used

    1 Attachment


Avatar for user136465 @user136465 started