• TL;DR: It works!

    Yesterday I gave the Espruino Pico one last shot trying my luck again to flashing the bootloader, still no success.
    I was a couple minutes ago I was in the process to cleanup all related tabs and call it a day, when I reloaded this thread and just then realized that you posted an answer already 10 days ago...It must have slipped through somehow...

    I downloaded the tool from the provided URL and followed this step-by-step instructions: https://doc.qt.io/QtForMCUs/qtul-flashin­ginstructions-st-bootloader.html

    Flashing worked just fine.
    After removing pencil marks on the BOOT0/BTN solder jumper, I could enter the bootloader mode just fine (LEDs keep pulsing, instead of changing to the "solid" state).

    I couldn't connect to the board though the device showed up in the serial port connection menu.
    I checked the trouble shooting section that exactly described this and after restarting first chrome and than my PC it now works flawlessly as far I can tell.
    (I had a error message in the Web IDE when flashing code to the device, that is now gone)

    Thank you gordon for being so helpful!