You are reading a single comment by @coat and its replies. Click here to read the full conversation.
  • Hi Robin and thanks for your help.

    So to confirm, as I understand the above, what does work is to cut-n-paste into the R-Hand editor side only?

    Yes, I can only write and cut-n-paste into the Right-Hand editor side. On the Left-hand side I can't do anything.

    Are you connected by the USB cable from a port on the PC? (to remove Bluetooth connectivity as a possibility using battery)

    Yes, I'm connected by USB. When I open Espruino IDE, I click on the Connect/Disconnect button on the top left corner and select COM8 mBed serial port.

    Was an attempt to disconnect or power down, then re-connect or power up, done?

    Yes, I have try yesterday and this morning too. On the left-hand editor side I see the message Unable to retrieve board information. Connection Error? and immediatly below Connected to COM8 (No response from board) but the code is upload correctly.

    After the numerous 'Initialising Utils, Initialising Config, . . .' entries, are any other errors reported within the IDE console output?

    I can see a Warning advise. Here you can find what console writes after all the initialising:

    No code in storage.
    GET = 0 bytes
    >>> Connecting...
    Set Slow Write = true
    [object Object]
    Connected [object Object]
    Got ""
    No Prompt found, got undefined - issuing Ctrl-C to try and break out
    Splitting for Ctrl-C, delay 250
    Still no prompt - issuing another Ctrl-C
    Splitting for Ctrl-C, delay 250
    >>> Sending...
    ---> "\u0010print(\"<\",\"<<\",JSON.stringify­(process.env),\">>\",\">\")\n"
    >>> Sent
    >>> Receiving...
    WARNING: No result found for "process.env" - just got ""
    ERROR: [notify_error] Unable to retrieve board information. Connection Error?
    Device found {"bitrate":115200,"bufferSize":4096,"con­nectionId":3,"ctsFlowControl":false,"dat­aBits":"eight","name":"","parityBit":"no­","paused":true,"persistent":false,"rece­iveTimeout":0,"sendTimeout":0,"stopBits"­:"one"}
    [success] Connected to COM8 (No response from board)
    >>> Connected to COM8 (No response from board)

    What IDE version is displayed?

    In Settings >> About I read 0.74.1

    From that image, I see that a recent flash of Espruino was done. Was this flashed using the WebIDE itself, or some other means?

    I have use just WebIDE

    While the Chrome browser is mentioned, what is the PC OS the Chrome browser is running on?

    Windows 10 21H1

    By chance have you tried the online IDE directly?

    Oh here works!
    Initially, when I have click Connect/Disconnect button then on Web Serial it has find mbed serial port COM8 it says Connection failed.
    Trying again, it has find MicrobitV2 and now I can write on left-hand emulator side and also the other examples work!

    But why?


Avatar for coat @coat started