• Thr 2021.09.30

    re: post #5 'Wow, and this sequence worked:'
    re: post #8 above
    re: post #15 success at   Firmware build for PICO fails - make: ***

    Well that was short lived.

    After several days of trial and error, I thought I had a work around using two separate 'make clean' steps.

    While that seemed to work, it is only around three out of five attempts. I have even tried switching the provision.sh targets, cleaning, build, then switching back to the desired target with limited success.

    Q: Is it necessary to run the provision.sh script each and every time a build is desired? (?no?)

    I've even verified after each clean step the the src and gen folders are gone of .o compiled files before I start the build.

    I'm wondering if there is some kind of file locking hiccup within Windows10 that blocks the ability of the make utility from writing the file timely, as the errors are never consistent. I'd like to isolate/eliminate whether it might be the file system.

    Q: Does anyone know of a trick to add a small delay between each .o file compile with make or gcc to slow down the build?


Avatar for Robin @Robin started