• Here is a Bangle.js 1 watch where the button BTN2 does not do anything.
    It has firmware 2v09. A few things were tried already, see below.

    As BTN2 does not work, so is there a way to flash the firmware without using BTN2?

    Is there a different way to reset or hard reset?

    Anything else I should try to get BTN2 working again?


    • Pressing on BTN2 does not wake up the clock.
    • Does not go into the menu, when pressed short or long, or repeatetly.
    • Does not initiate reset or reset into flashing when pressing to gether with BTN1.


    BTN2 was working so far. Flashed to 2v09 and BTN2 was also working.

    Watch wasn't used much for a few weeks and wasn't switched off, so it is assumed that the battery ran completely low. It did charge fine and came up. Since then BTN2 is not working, and I think the watch could also not be resetted.

    Can connect. Updated all apps. Also tried to reinstall to default apps, this got me a few errors and got stuck. Then erased all apps and installed bootloader, morphing clock, menu and so on. Holding BTN3 reloads, but not reset and no working BTN2.


Avatar for ber @ber started