• Back again with the same issue! Not sure what's triggering it to happen exactly, but it's the exact same error message. I tried the "Web Bluetooth / Device Info Sample" on Google Chrome's github.io page (this), and it was able to detect the watch fine with the characteristic, but the IDE returns the error originally mentioned ("BT> ERROR: NotFoundError: No Services matching UUID 6e400001-b5a3-f393-e0a9-e50e24dcca9e found in Device."). I've tried everything that I tried that got it to work last time, but to no avail. (restarting both bangle and laptop multiple times, reflashing bangle firmware, toggling all features of BLE on the bangle several times, reinstalling bluetooth-related packages on laptop)

    It might be worth mentioning that I let the Bangle sit unused for a while (got an infection on my wrist for unrelated reasons).

    I'm truly at a loss at this point. Attached is a screenshot of the Chrome DevTools, around the related section of the logs.

    1 Attachment

    • ChromeDevTools_BangleUUIDError.png

Avatar for user127585 @user127585 started