• What with not leaving my house much for some reason, I hadn't turned on my Bangle for a while, probably over 3 weeks. When I tried yesterday, it was dead. I tried button 1, then 1+2, then every combination I could think of for 10 seconds at a time. Nothing.

    I charged it for a couple of hours and tried again. Nothing still. That is, I magnetically adhered the cable that came with the watch, which was plugged into a voltage source.

    I was literally in the middle of posting this message when my years of experience with USB cables kicked in and I had to revise. USB cables fail. So I found the charging cable from an old smartwatch, which happened to be identical to the Bangle cable, plugged that in, and the watch started immediately. It had run down to zero power during the long disuse, and coincidentally the Espruino-supplied charging cable had failed. Luckily, another cable I had lying around coincidentally could be a substitute.

    So, this message went from "request for help" to "maybe you need higher-quality cabling," I guess.


Avatar for CarlF @CarlF started