You are reading a single comment by @Vladimir and its replies. Click here to read the full conversation.
  • Hi,
    I have not found my case in Troubleshooting. So I'm describing the problem here.

    • The Esp WIFI with the same cable works fine with Win10.
    • In Win7 I've got the board in Windows Control Panel's 'Devices and Printers' page - 'STMicroelectronics Virtual COM Port (COM8)'. The status is Ok. The IDE reports 'searching ... no ports found'. I tried all different options: reinstalled drivers, reinstalled WEB-ide, reset and cleaned COM ports. No changes.
      Moreover when i Hold down the button, and then plug the board in while keeping it held, I get 'Red and Green light brightly for a fraction of a second, then they start 'pulsing', and sound signal of a connection to PC. But nothing happens on the side of IDE
  • Sun 2020.09.19

    Hi @Vladimir,

    Has this page been referenced?­#my-board-doesn-t-appear-as-a-usb-serial­-port-in-windows

    See heading: 'My board doesn't appear as a USB . . . '
    Instructions for pre Windows10

    re: ''Red and Green light brightly for a fraction of a second, then they start 'pulsing''

    Same link as above, see heading 'Espruino stopped working'
    "If you get pulsing Red/Green LEDs, it's because . . . "

    For clarification, is the intent to reflash the WiFi, or is it that the WebIDE just is not recognizing the COM port?

  • Have you tried the native ide? I think with the web ide you need to enable WebUSB in chrome via chrome://flags/#new-usb-backend

    The native ide should work better when programming through the serial port though. (I use a pico though and windows 10, so your mileage may vary)


Avatar for Vladimir @Vladimir started