You are reading a single comment by @Gordon and its replies. Click here to read the full conversation.
  • the thing that solved it for me was the 'throttle send' option in the communications section of settings

    That's great - but you should be aware that it hasn't solved the underlying problem, so at some point you might have code that takes a lot longer to execute, and that'll cause you similar issues.

    It's good to hear what issues people hit when they just dive right in. I'll see if I can find a way of making the Web IDE detect common errors on the left-hand side and offer advice (eg. 'try this on the right-hand side, or do you want to upload the module?')

    The upload issue is unfortunate - on the USB-based boards there's flow control within the USB com port, so lost characters really aren't a problem. However the Bluetooth LE UART implementation doesn't have any flow control. That's rarely a problem since the transfer rate is pretty slow, but in some cases (which you just hit!) one command will take long enough to execute that it's still enough to cause problems.

    I'll see if I can get some flow control implemented for the uploads on top of Bluetooth for the next version though, which should avoid issues like this.


Avatar for Gordon @Gordon started