• THE ACTUAL SOLUTION: D1 MINI BOARDS (or most of them, at least) NEED TO BE FLASHED IN dio MODE NOT qio (and GPIO9 and 10 can be used - though they aren't brought out to pins on the D1 mini boards). There is NO DEFECT ON THESE BOARDS - it was USER ERROR on my part! It has come to my attention that people are citing this thread as a proof that these boards are no good - that is TOTALLY UNTRUE!

    They don't need any of the modifications discussed below (other than if you actually do need QIO for performance, in which case you either remove the module from one with a torch or heat-gun (I found them just a bit too much for my heat gun; the torch worked way better), or buy a D1 mini without the ESP module from robotdyn on aliexpress and mount your own QIO-supporting ESP-12 on it).


    I'd really like to get Espruino running on some Wemos D1 Mini boards - it would let me save a huge amount of space in a very tightly packed room. But I can't seem to get it running the first time.

    I flashed v1.95 with

    Z:\ESPTOOL\espruino_1v95_esp8266_4mb>..\­esptool.py --port COM3 --baud 115200 write_flash --flash_freq 80m --flash_mode qio --flash_size 4MB-c1 0x0000 boot_v1.6.bin 0x1000 espruino_esp8266_user1.bin  0x3FC000 esp_init_data_default.bin 0x3FE000 blank.bin

    But now when I try to connect to it with hterm (at 115200 baud, which works for naked ESP12F's) to configure the wifi, I'm clearly not talking to Espruino. It seems like it might be stuck in the bootloader?

    When I press reset with serial terminal connected, I get a bunch of garbage - like the wrong baud rate is selected, except I can't figure out what the right baud rate is. It looks like the ESP8266 likes to use some obscenely high baud rate, 460800 (is that the baud rate I should use to see WTF it's outputting?) - but none of my serial console software gives me an option to select that baud rate; I tried downloading several terminal programs, and none would go higher than 230400. Does anyone know of a program that will (assuming that's the correct baud rate)?

    I originally thought I had a defective board, and wound up trashing the board trying to figure this out (as I started pulling everything connected to the strapping pins off the board ("There's gotta be something about this WeMos stuff that's holding the strapping pins in the wrong state, so remove everything that seems to be connected to it" but nothing I did seemed to fix the behavior I was seeing. The second board behaves the same as the first though, so it seems like it's something wrong with what I'm doing, not with the board I had.

    Has anyone managed to get these to work? What am I missing? I suspect it's something really simple here, but I've put I'd say 5-6 hours into it at this point, and am no closer to making it work than I was when I started.



Avatar for DrAzzy @DrAzzy started