I changed it to this, at least for now:
const wifi = require("EspruinoWiFi"); function getIP() { wifi.getIP(function(err, info) { if (err) setTimeout(getIP, 1000) console.log('IP:', info.ip) }); } getIP();
Could it be better?
@trusktr started
Espruino is a JavaScript interpreter for low-power Microcontrollers. This site is both a support community for Espruino and a place to share what you are working on.
I changed it to this, at least for now:
Could it be better?