You are reading a single comment by @Wilberforce and its replies. Click here to read the full conversation.
  • @JumJum

    Couple of corrections...

    The spi Neil added were just stubs, I have fleshed them out properly, and tried to get working with a Nokia display - no success yet, but getting close.

    The i2c is working - I have tested writing 8 bit to an i2c display - I've got output, but input has not been tested. An i2c scan does not work properly.

    One wire should work but doesn't yet. I'm not sure if interupts are the issue- I've tried to disable them, but not working yet. It could be related to the timings- I've got a few things to try yet. I don't have anything to measure the logic levels - using a led I can see it is on faintly which suggests the pin is toggling state.

    Gpio is now working for all pins, and a setwatch on the inbuilt flash button is working.

    The telnet sources compile - and it appears to listen on the port - but no input or output.

    Websockets are working, the crypto sources all compile, but https is not working yet. Might need @Gordon s help to debug when he is less busy!


Avatar for Wilberforce @Wilberforce started