• It now builds again but still no serial ports.

    I also tried

    sudo electron-rebuild --version 0.36.11


    Couldn't find electron-prebuilt and no --node-module-version parameter set, always rebuilding
    > nslog@3.0.0 install /usr/local/lib/node_modules/electron-reb­uild/node_modules/nslog
    > node-gyp rebuild
    gyp ERR! clean error
    gyp ERR! stack Error: EACCES: permission denied, unlink 'build/Makefile'
    gyp ERR! stack     at Error (native)
    gyp ERR! System Linux 4.1.19-v7+
    gyp ERR! command "/usr/local/bin/node" "/usr/local/lib/node_modules/electron-re­build/node_modules/npm/node_modules/node­-gyp/bin/node-gyp.js" "rebuild"
    gyp ERR! cwd /usr/local/lib/node_modules/electron-reb­uild/node_modules/nslog
    gyp ERR! node -v v4.4.0
    gyp ERR! node-gyp -v v3.3.0
    gyp ERR! not ok
    npm ERR! Linux 4.1.19-v7+
    npm ERR! argv "/usr/local/bin/node" "/usr/local/lib/node_modules/electron-re­build/node_modules/npm/bin/npm-cli.js" "rebuild" "--runtime=electron" "--target=0.36.11" "--arch=arm"
    npm ERR! node v4.4.0
    npm ERR! npm  v3.8.1
    npm ERR! code ELIFECYCLE
    npm ERR! nslog@3.0.0 install: `node-gyp rebuild`
    npm ERR! Exit status 1
    npm ERR!
    npm ERR! Failed at the nslog@3.0.0 install script 'node-gyp rebuild'.
    npm ERR! Make sure you have the latest version of node.js and npm installed.
    npm ERR! If you do, this is most likely a problem with the nslog package,
    npm ERR! not with npm itself.
    npm ERR! Tell the author that this fails on your system:
    npm ERR!     node-gyp rebuild
    npm ERR! You can get information on how to open an issue for this project with:
    npm ERR!     npm bugs nslog
    npm ERR! Or if that isn't available, you can get their info via:
    npm ERR!     npm owner ls nslog
    npm ERR! There is likely additional logging output above.
    npm ERR! Please include the following file with any support request:
    npm ERR!     /usr/local/lib/node_modules/npm-debug.lo­g
    Process exited with code: 1
    Error: Process exited with code: 1
        at ChildProcess.<anonymous> (/usr/local/lib/node_modules/electron-re­build/lib/spawn.js:55:26)
        at emitTwo (events.js:87:13)
        at ChildProcess.emit (events.js:172:7)
        at maybeClose (internal/child_process.js:827:16)
        at Process.ChildProcess._handle.onexit (internal/child_process.js:211:5)

    I need to try on a non-RPi box to see if it's Pi or ARM specific.


Avatar for conor @conor started