Avatar for crow_t_robot

crow_t_robot

Member since Oct 2021 • Last active Jan 2022
  • 2 conversations
  • 8 comments

Ruby/Rails, Go developer. Don't know squat about Javascript, but I guess I'm going to be learning it now. :)

Most recent activity

  • in Bangle.js
    Avatar for crow_t_robot

    Yep, that sounds just like my problem, too.

  • in Bangle.js
    Avatar for crow_t_robot

    If you are talking about the HID setting on the bangle, I made sure that it is turned off. Now, when I was initially playing around with all of this, I did turn HID on, but then I turned it off and still can't get things working.

    So, if I understand you correctly, Gordon, you are saying that when I had HID turned on on the bangle, it may have auto paired with some bluetooth device in my house (other than my laptop or my phone) which I have checked. That's why it is showing as "Paired" when I try to connect to it from Chrome on my laptop, even though it does not appear to be paired with my laptop.

    I'll keep messing with it. Thanks for the help, Gordon.

  • in Bangle.js
    Avatar for crow_t_robot

    I have a similar problem. I was messing around with Gadgetbridge and then I removed it and started messing around with just the Music Controls widget. Anyway, I couldn't get it working correctly with my phone's music player, so I just wanted to get everything back to normal so I could connect to Chrome running on my linux pc again, but I can no longer connect to my pc.

    I've deleted Gadgetbridge from my phone, even turned off bluetooth from my phone. I've disconnected my bangle from my laptop in "Bluetooth Settings". Then I go to banglejs.com/apps and click on "Connect". The popup screen appears showing "Banglejs -- Paired" as if it is already paired, which it is not. I click on "Pair" and it shows "Device connection failed".

    I tried the "Resetting without loading any code" and that does not help. I've got "Make Connectable", "Programmable", and "BLE" on and "HID" off in the banglejs bluetooth settings.

    Any ideas?

  • in Bangle.js
    Avatar for crow_t_robot

    So, when I first asked my wife to get me a Banglejs for Christmas, my one goal was to make my own clock with the face of Crow T. Robot, my favorite MST3K character, as the background. If I could do that, I would be over the moon.

    Well, since I unwrapped my watch, I've messed around here and there, downloading different apps, tinkering with the source code of several of them, and going through some of the tutorials.

    Today, I stole most of the code from Bold Clock (thanks, Ivan!) and was able to cobble together a little clock for my banglejs. You can see what it looks like in the attached screenshot.

    I don't care if I ever get to do anything else cool with my watch. I'm a happy camper! Now to go through the app tutorials again and figure out how to make it into a real app.

    Gordon, thanks for making my Christmas wish come true!

  • in Bangle.js
    Avatar for crow_t_robot

    Thank you! I will try the above suggestions.

  • in Bangle.js
    Avatar for crow_t_robot

    Hi! I got a banglejs2 for Christmas and I'm having a blast playing with it and following the tutorials! Thank you, Gordon and thank you everyone who has contributed an app. :)

    Speaking of the latter, I'm using the awesome LCARS clock, but I can't seem to get to the settings menu for it. I go to the launcher and launch "Settings", I open the "Apps" submenu, and I see an entry for stuff like "Launcher" and "Pedometer", but there is no entry for "LCARS Clock".

    I've looked at the source code for LCARS in github and I can see that it does have a lcars.settings.js file and I see what looks like the correct entries in the global apps.js file, at least it looks correct based on the tutorial code I read about adding a settings function to your app. But, for some reason, it is not showing up under the "Settings" on my watch.

    Does anyone have any idea what might be wrong on my watch?

    Thanks!

  • in Bangle.js
    Avatar for crow_t_robot

    Great! It now works in Firefox. Although, I did have to load Chrome first. I'm assuming that even though it is working now in Firefox, I still need to keep Chrome on my machine, since it needs the Web Serial and Web Bluetooth libs?

    Anyway, thanks for getting it working on Firefox.

Actions