Avatar for Chuvak2007f

Chuvak2007f

Member since Jan 2021 • Last active Jan 2021
  • 1 conversations
  • 7 comments

Most recent activity

  • in ESP8266
    Avatar for Chuvak2007f

    Here are sequentially screenshots of the IDE when connected to the board.




    Maybe the problem is in the IDE settings or in the drivers? I am using windows 8.1.

  • in ESP8266
    Avatar for Chuvak2007f

    What happens if you try hitting enter in the IDE a couple of times?

    Nothing happens

    Do you get a new prompt (the > character)?

    No

    Or what happens if you type 1+2 and hit enter?

    Input is blocked in IDE. Below the inscription: CONNECTED TO COM8 (NO RESPONSE FROM BOARD)

  • in ESP8266
    Avatar for Chuvak2007f
    cd "D:\Espruino\firmware"
    
    $ python "../esptool/esptool.py" --port COM8 erase_flash
    esptool.py v3.1-dev
    Serial port COM8
    Connecting....
    Detecting chip type... ESP8266
    Chip is ESP8266EX
    Features: WiFi
    Crystal is 26MHz
    MAC: cc:50:e3:df:01:5e
    Uploading stub...
    Running stub...
    Stub running...
    Erasing flash (this may take a while)...
    Chip erase completed successfully in 13.2s
    Hard resetting via RTS pin...
    
    $ python "../esptool/esptool.py" --port COM8 --baud 115200 write_flash --flash_freq 80m --flash_mode qio --flash_size 32m 0x0000 boot_v1.6.bin 0x1000 espruino_esp8266_user1.bin 0x3FC000 esp_init_d                                                                           ata_default.bin 0x3FE000 blank.bin
    WARNING: Flash size arguments in megabits like '32m' are deprecated.
    Please use the equivalent size '4MB'.
    Megabit arguments may be removed in a future release.
    esptool.py v3.1-dev
    Serial port COM8
    Connecting....
    Detecting chip type... ESP8266
    Chip is ESP8266EX
    Features: WiFi
    Crystal is 26MHz
    MAC: cc:50:e3:df:01:5e
    Uploading stub...
    Running stub...
    Stub running...
    Configuring flash size...
    Flash params set to 0x004f
    Compressed 3856 bytes to 2763...
    Writing at 0x00000000... (100 %)
    Wrote 3856 bytes (2763 compressed) at 0x00000000 in 0.3 seconds (effective 95.2 kbit/s)...
    Hash of data verified.
    Compressed 534596 bytes to 350986...
    Writing at 0x00001000... (4 %)
    Writing at 0x00005f4f... (9 %)
    Writing at 0x0000aff7... (13 %)
    Writing at 0x000103f6... (18 %)
    Writing at 0x00016fda... (22 %)
    Writing at 0x0001d856... (27 %)
    Writing at 0x00023cdd... (31 %)
    Writing at 0x0002b04b... (36 %)
    Writing at 0x000334f9... (40 %)
    Writing at 0x0003a225... (45 %)
    Writing at 0x00040317... (50 %)
    Writing at 0x000463fb... (54 %)
    Writing at 0x0004c4dc... (59 %)
    Writing at 0x00052511... (63 %)
    Writing at 0x000577a2... (68 %)
    Writing at 0x0005cde4... (72 %)
    Writing at 0x00062490... (77 %)
    Writing at 0x00067d37... (81 %)
    Writing at 0x0006d4d6... (86 %)
    Writing at 0x0007355a... (90 %)
    Writing at 0x0007b267... (95 %)
    Writing at 0x00080532... (100 %)
    Wrote 534596 bytes (350986 compressed) at 0x00001000 in 32.3 seconds (effective 132.3 kbit/s)...
    Hash of data verified.
    Compressed 128 bytes to 75...
    Writing at 0x003fc000... (100 %)
    Wrote 128 bytes (75 compressed) at 0x003fc000 in 0.1 seconds (effective 16.3 kbit/s)...
    Hash of data verified.
    Compressed 4096 bytes to 26...
    Writing at 0x003fe000... (100 %)
    Wrote 4096 bytes (26 compressed) at 0x003fe000 in 0.1 seconds (effective 520.1 kbit/s)...
    Hash of data verified.
    
    Leaving...
    Hard resetting via RTS pin...
    
    $ pyserial-miniterm COM8 115200
    --- Miniterm on COM8  115200,8,N,1 ---
    --- Quit: Ctrl+] | Menu: Ctrl+T | Help: Ctrl+T followed by Ctrl+H ---
    ;{lp�o�␐␃␌␌{�����␌␌␌␄#␄o�|␃쎎�b��no�␂␄␌l`­␂�␛␛no␄$`␂␏␃n{���o␌␌␃␌�␎lp�n�␐␃␌␄r������­l␄␄#␄n�|␃��␜�␄#��nn�␃␌␄$ ␃�␒␒on␌l`␂␎␂o{����␃␌␌�␂$ ␃␏{��o␄␄�␃l`␂{l��o܌�nn����r␛nnn�␄$�b�{$␀­␄�␒�l�␛�ۂ␂␄␄␌␌␌�␌␄␄$$d~{$                                                                           ␀␌�␒�$dln��␀␌␄␄␄␄␌�␌l�$$␎l␀␄�␛�l��o�␂n��­n~␒␂��$l�#␌�$$p"�␃b{���$ nl����l b$ ␃$��n␂␄�o���n$�|␒b␛␌␀␃$␄␄␌l`␂{l��␃�␒�o��­r��n|�␄$␌l$$`␂␜c�␒␃␌�|␂r�␃$�n�␄�o�␀␌l ␃��{�d�l␒�␛[?7l
     ____                 _
    |  __|___ ___ ___ _ _|_|___ ___
    |  __|_ -| . |  _| | | |   | . |
    |____|___|  _|_| |___|_|_|_|___|
             |_| espruino.com
     2v08 (c) 2019 G.Williams
    
    Espruino is Open Source. Our work is supported
    only by sales of official boards and donations:
    http://espruino.com/Donate
    Flash map 4MB:512/512, manuf 0x1c chip 0x3016
    
    >
    
    

    The firmware is uploaded without problems. But the board doesn't connect to IDE ...

  • in ESP8266
    Avatar for Chuvak2007f

    I use git bash for Windows.

    cd "D:\Espruino"
    
    git clone https://github.com/espressif/esptool
    
    cd "D:\Espruino\firmware"
    
    python "../esptool/esptool.py" --port COM8 erase_flash
    
    python "../esptool/esptool.py" --port COM8 --baud 115200 write_flash --flash_freq 80m --flash_mode qio --flash_size 32m 0x0000 boot_v1.6.bin 0x1000 espruino_esp8266_user1.bin 0x3FC000 esp_init_data_default.bin 0x3FE000 blank.bin
    
    

    D:\Espruino\firmware\ == http://www.espruino.com/files/espruino_2­v08.zip -> espruino_2v08_esp8266_4mb

  • in ESP8266
    Avatar for Chuvak2007f

    What kind of ESP8266 board do you have?

    NodeMCU v2 or v3 - I'm not exactly sure which version.

    What happens if you press reset on the ESP8266 while the IDE is
    connected?

    The error is the same..

    Connected to COM8 (No response from board)
    
  • in ESP8266
    Avatar for Chuvak2007f

    Hi All! Need help.

    Espruino IDE (Native) espruino_ide_win64_0v72.1
    Firmware ESP8266 2v08

    IDE Error:

    rl$Üß|�$à|���lä�#|���ìr�b�b�ûoo�$onÜãä#�p��l{${$pòoà����$��#�oã|������c�ûnnî�$��l`�
    Unable to retrieve board information. Connection Error?
    Connected to COM8 (No response from board)
    

    I set in the IDE-COMMUNICATIONS-Baud Rate = 115200 !

    There is a connection via the COM-terminal, but the IDE does not want to connect! What is the problem?

    IDE-CONSOLE:

    We have chrome.serial - not using 'serialport' module
    Disable Web Bluetooth as we have Winnus instead
    serial_audio: Audio Sample rate : 192000
    serial_audio: Audio Serial Baud 9600 Bit time 20
    Loading UTF8 with require
    GET chrome.storage.sync = {"AUTO_SAVE_CODE":true,"BAUD_RATE":"1152­00","BLOCKLY_EXTENSIONS":"|bluetooth|rob­ot|","BLOCKLY_LANGUAGE":"en","BLOCKLY_TO­_JS":false,"BLUETOOTH_LOW_ENERGY":true,"­BOARD_JSON_URL":"http://www.espruino.com­/json","CODE":"var  on = false;\nsetInterval(function() {\n  on = !on;\n  LED1.write(on);\n}, 500);","COMPILATION":true,"COMPILATION_U­RL":"https://www.espruino.com/service/co­mpiler","DISABLE_CODE_HINTS":false,"ENAB­LE_Testing":false,"ENV_ON_CONNECT":true,­"FONT_SIZE":12,"KEYMAP":"sublime","MINIF­ICATION_DeadCode":true,"MINIFICATION_LEV­EL":"","MINIFICATION_Literal":true,"MINI­FICATION_Mangle":true,"MINIFICATION_Unre­achable":true,"MINIFICATION_Unused":true­,"MODULE_AS_FUNCTION":true,"MODULE_EXTEN­SIONS":".min.js|.js","MODULE_MINIFICATIO­N_LEVEL":"","MODULE_PROXY_ENABLED":false­,"MODULE_PROXY_PORT":"","MODULE_PROXY_UR­L":"","MODULE_URL":"https://www.espruino­.com/modules","OFFLINE_DATA":"","OFFLINE­_DATA_DOWNLOAD":"","OFFLINE_DATA_UPLOAD"­:"","OFFLINE_ENABLED":false,"PRETOKENISE­":false,"RESET_BEFORE_SEND":true,"SAVE_O­N_SEND":0,"SERIAL_AUDIO":"0","SERIAL_FLO­W_CONTROL":true,"SERIAL_IGNORE":"/dev/tt­yS*|/dev/*.SOC|/dev/*.MALS","SERIAL_TCPI­P":"","SERIAL_THROTTLE_SEND":false,"SET_­TIME_ON_WRITE":false,"SHOW_CODE_LINK_ICO­N":false,"SHOW_WEBCAM_ICON":0,"STORE_LIN­E_NUMBERS":true,"Sound_Error":"","Sound_­Info":"","Sound_Success":"","Sound_Warni­ng":"","Speak_Error":false,"Speak_Info":­false,"Speak_Success":false,"Speak_Warni­ng":false,"UI_MODE":"Normal","WEBCAM_CON­STRAINTS":0,"WEB_SERIAL":true}
    Initialising SettingsConsole
    Initialising Utils
    Initialising Config
    Initialising Notifications
    Initialising Status
    Initialising App
    Initialising File
    Initialising Code
    Initialising Serial
      - Initialising Serial Chrome Serial
      - Initialising Serial Chrome Socket
      - Initialising Serial Noble Bluetooth LE
      - Initialising Serial Windows Bluetooth LE
      - Initialising Serial Web Audio
      - Initialising Serial Web Bluetooth
      - Initialising Serial Web Serial
    Initialising Terminal
    Initialising CodeWriter
    Initialising Modules
    Initialising Env
    Initialising Flasher
    Initialising EditorBlockly
    Initialising EditorJavaScript
    Initialising Send
    Initialising MenuPortSelector
    Initialising MenuSettings
    Initialising MenuFlasher
    Initialising SettingsAbout
    Initialising SettingsFlasher
    Initialising BoardJSON
    Initialising VersionChecker
    Initialising Compiler
    Initialising Assembler
    Initialising GetGitHub
    Initialising Unicode
    Initialising Minify
    Initialising Pretokenise
    Initialising SaveOnSend
    Initialising SetTime
    Initialising Tutorial
    Initialising Webcam
    Initialising FontSize
    Initialising UiMode
    Initialising URLHandler
    Initialising CodeLink
    Initialising Project
    Initialising Testing
    Initialising Notification_Sound
    Initialising Tern
    Initialising Debugger
    Initialising Tour
    Initialising SettingsProfile
    Initialising HelpLinks
    Initialising Offline
    Initialising CoreModules
    Loaded code from storage.
    GET chrome.storage.local.OFFLINE_DATA = 799783 bytes
    Noble: module couldn't be loaded, no node.js Bluetooth Low Energy  Error: Cannot find module '@abandonware/noble'
    Web Bluetooth available, but Windows Web Bluetooth is broken in <68 - not using it
    No navigator.serial - Web Serial not enabled
    >>> Connecting...
    Set Slow Write = true
    [object Object]
    Connected [object Object]
    ERROR: RECEIVE ERROR: {"connectionId":1,"error":"frame_error"}­
    Disconnect callback...
    WARNING: [notify_warn] Disconnected
    >>> Disconnected
    ERROR: executeExpression called when not connected!
    ERROR: [notify_error] Unable to retrieve board information. Connection Error?
    Device found {"bitrate":115200,"bufferSize":4096,"con­nectionId":1,"ctsFlowControl":false,"dat­aBits":"eight","name":"","parityBit":"no­","paused":false,"persistent":false,"rec­eiveTimeout":0,"sendTimeout":0,"stopBits­":"one"}
    [success] Connected to COM8 (No response from board)
    >>> Connected to COM8 (No response from board)
    
Actions