Avatar for user65995

user65995

Member since Jul 2016 • Last active Jul 2016
  • 1 conversations
  • 1 comments

Most recent activity

    • 3 comments
    • 743 views
  • in ESP8266
    Avatar for user65995

    Hi Guys,

    I purchased this board on Amazon.

    https://www.amazon.com/gp/product/B010O1­G1ES/ref=oh_aui_detailpage_o00_s00?ie=UT­F8&psc=1

    And tried flashing EspRuino onto the device:

    ..\esptool\esptool.py --port COM4 --baud 460800 write_flash --flash_freq 40m --flash_mode qio --flash_size 4m 0x0000 "boot_v1.5.bin" 0x1000 espruino_esp8266_user1.bin 0x7E000 blank.bin

    No errors and everything looked like it worked, but when I run the EspRuino web IDE - I'm able to connect but following the examples in the quick tutorial don't seem to work

    Typing 1+1 doesn't output anything in the console.

    Going to Settings > Console shows the below:

    What am I missing here?

    ============

    GET chrome.storage.sync = {"AUTO_SAVE_CODE":true,"BAUD_RATE":9600,­"BLOCKLY_TO_JS":false,"BOARD_JSON_URL":"­http://www.espruino.com/json","CODE":"va­r on = false;\nsetInterval(function() {\n on = !on;\n LED1.write(on);\n}, 500);","COMPILATION":true,"COMPILATION_U­RL":"http://www.espruino.com:32766","ENABLE_T­esting":false,"ENV_ON_CONNECT":true,"FON­T_SIZE":12,"MINIFICATION_DeadCode":true,­"MINIFICATION_LEVEL":"","MINIFICATION_Li­teral":true,"MINIFICATION_Mangle":true,"­MINIFICATION_Unreachable":true,"MINIFICA­TION_Unused":true,"MODULE_EXTENSIONS":".­min.js|.js","MODULE_MINIFICATION_LEVEL":­"ESPRIMA","MODULE_URL":"http://www.espru­ino.com/modules","NPM_MODULES":false,"RE­SET_BEFORE_SEND":true,"SAVE_ON_SEND":fal­se,"SERIAL_AUDIO":"0","SERIAL_TCPIP":"",­"SERIAL_THROTTLE_SEND":false,"SET_TIME_O­N_WRITE":false,"SHOW_CODE_LINK_ICON":fal­se,"SHOW_RELOAD_ICON":false,"SHOW_WEBCAM­_ICON":false,"STORE_LINE_NUMBERS":true,"­Sound_Error":"","Sound_Info":"","Sound_S­uccess":"","Sound_Warning":"","Speak_Err­or":false,"Speak_Info":false,"Speak_Succ­ess":false,"Speak_Warning":false,"UI_MOD­E":"Normal"}
    Initialising Utils
    Initialising Config
    Initialising Notifications
    Initialising Status
    Initialising App
    Initialising File
    Initialising Code
    Initialising Serial
    Initialising Terminal
    Initialising CodeWriter
    Initialising Modules
    Initialising Env
    Initialising Flasher
    Initialising EditorBlockly
    Initialising EditorJavaScript
    Initialising Send
    Initialising MenuPortSelector
    Initialising MenuSettings
    Initialising MenuFlasher
    Initialising SettingsAbout
    Initialising SettingsFlasher
    Initialising SettingsConsole
    Initialising BoardJSON
    Initialising VersionChecker
    Initialising Compiler
    Initialising Assembler
    Initialising GetGitHub
    Initialising NPMModules
    Initialising ExamplePlugin
    Initialising Unicode
    Initialising SaveOnSend
    Initialising Minify
    Initialising Tutorial
    Initialising Webcam
    Initialising FontSize
    Initialising UiMode
    Initialising URLHandler
    Initialising FileReload
    Initialising CodeLink
    Initialising Project
    Initialising Testing
    Initialising Notification_Sound
    Initialising Tern
    Initialising Debugger
    Initialising Tour
    Initialising SettingsProfile
    Loaded code from storage.

    Connecting...
    Set Slow Write = true
    [object Object]
    Connected [object Object]
    ERROR: RECEIVE ERROR: {"connectionId":6,"error":"overrun"}
    Disconnect callback...
    Disconnected
    ERROR: executeExpression called when not connected!
    Connecting...
    Set Slow Write = true
    [object Object]
    Connected [object Object]
    Found a prompt... great!
    Sending...
    ---> "echo(0);\nconsole.log(\"<\",\"<<\",JSON­.stringify(process.env),\">>\",\">\");ec­ho(1);\n"
    Sending block "echo(0);\nconsol", wait 50ms
    Sent
    Sending block "e.log(\"<\",\"<<\",", wait 50ms
    Sent
    Sending block "JSON.stringify(", wait 50ms
    Sent
    Sending block "process.env),\">", wait 50ms
    Sent
    Sending block ">\",\">\");echo(1)", wait 50ms
    Sent
    Sending block ";\n", wait 50ms
    Sent
    Sent
    WARNING: No result found - just got ""
    Device found (connectionId=7)
    Connected to port COM4
    Sending block "1", wait 50ms
    Sent
    Sending block "+", wait 50ms
    Sent
    Sending block "1", wait 50ms
    Sent
    Sending block "\r", wait 50ms
    Sent
    Disconnect callback...
    Disconnected

Actions