Web Bluetooth Connection / App Loader / Fedora 36

Posted on
  • Hi there,

    It's been a while since I posted here and used my bangle.js 2. Since my last post, I still don't have any luck connecting my bangle to my the app loader on my phone (GrapheneOS) or on my laptop (Fedora 36).

    I have had success using gadgetbridge but I have little hope of getting my bangle to connect to the app loader on GrapheneOS since it is a secure OS and probably has bluetooth limitations. I can live without this, but I would like to be able to connect my bangle to the app loader on my laptop.

    I have used almost every chromium browser I can including: ungoogled chromium, chromium, chrome, edge, and brave. I've followed the web bluetooth guide on espruino and enabled the chrome flags and relaunched on each browser. I've tried connecting and disconnecting to my bluetooth manager on Fedora before trying the app loader on the browser. The bangle seems to connect to my laptop well. However, no matter what I do, when I click the connect button on my browser it says 'device connection failed'. When I navigate to this page: https://www.espruino.com/Quick+Start+BLE­#with-web-bluetooth it tells me that 'Web Bluetooth is already enabled on this computer.' and the same message appears on both https://www.puck-js.com/go and https://www.espruino.com/ide/. So my question is, how do I fix this? Does anyone else here use Fedora and managed to get their bangle connected?

    I know Gordon uses Linux Mint and I've seen various other posts on here of people using other linux distributions such as Ubuntu, but no other mention of Fedora.

    I thought parhaps maybe I just needed to install bluez but it appears that bluez comes packaged with Fedora 36 and when I type bluetoothctl --version into the terminal it tells me 5.65 is installed so that can't be the issue either.

    It seems web bluetooth is enabled in the browser, Fedora itself has functioning bluetooth capabilities already installed, and it seems my bangle can connect to the gadgetbridge app and bluetooth manager on my laptop. It appears to be a problem with the browser somehow but I'm really stuck and wondering it someone here can offer some help/suggestions.

    I'm thinking it must be something small that I've overlooked or just don't have the knowledge to fix. I really want to use my bangle but it's impossible to use if I can't connect to it to loads any apps.

    Thanks for any help!

  • Hi, I’m using fedora 36 silverblue with flatpak chromium without issues.

    If you are using flatpak then you need to give Bluetooth privileges to chromium.

    Simplest is to use “flatseal” to modify permissions and privileges.

  • Hi Marcus,

    Thanks so much for your reply. I've been using flatpaks and didn't realise that bluetooth privileges weren't given by default. I really appreciate your suggestion, going to download flatseal now and give it a go. I'll let you know how it goes:)

  • Hi again Marcus,

    Just want to thank you for your help. I finally got my bangle to work with Fedora! I installed flatseal and gave bluetooth privileges to chromium but that still didn't help. But your mention of flatpaks made me think of trying to install the rpm version of Chromium and that worked with no issues at all.

    Not sure why it won't work on the flatpak version but for now I'm just happy to have it working at all.

    Thanks again :)

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview
About

Web Bluetooth Connection / App Loader / Fedora 36

Posted by Avatar for sconniebotland @sconniebotland

Actions