BTHRM issue depending on the firmware version.

Posted on
  • With the latest firmwares v14.12 and v14.14, I have issues with my external BTHRM. Technically, the bthrm app sees the polar device when I scan (in settings), but then, when I start the bthrm app, there's nothing coming out from BTHRM, I don't get any data out of it, only the wrist HRM. I was thinking that my external device is dead, but I flashed the firmware V13 and the data reached the watch. V14 also works fine.
    I'm an early backer and I flashed almost every latest firmware as soon as it was available. This issue disappeared and reappeared on a regular basis. I have no technical knowledge, but from my perspective, some versions of the firmware break the transmission of the BTHRM data to the watch.

  • Hmm, that's interesting - thanks! 2v14.12ish did add the framework to allow multiple bluetooth connections out of the Espruino device which is quite a big change, and I wonder if something got broken there. I'll have a look today and see if I can spot anything.

  • Ok, just fixed! Looks like bthrm was doing some fancy stuff trying to cache characteristics to get it to connect faster, and with the newer firmwares that are capable of connecting to multiple devices, the BluetoothRemoteGATTCharacteristic now needs to reference the device it's for.

  • Yees ! It works with your oh-so-quick fixes !

  • Hi,
    Exactly the same problem with 2v14.59 and 2v14.63. I went back to 2v14 and it works like a charm.

  • Argh, sorry about that - I've been doing a lot of low-level bluetooth improvements recently and it looks like I messed this up. I've just put a fix in so it should be sorted in 2v14.65

  • Ah, 2v14.79 doesn't work either, but I come back with a potentially useful feedback (at last !). The bthrm app shows 2 sentences:"resetting trying time" and "set timeout for device as 100" they alternate at high speed and it took me a while to decypher these.
    Now 2v14.80 is being uploaded. More news soon.

  • 2v14.80 doesn't work either. Actually there are more alternated sentences that blink in the bottom of the screen, I could get "resetting retry time".

  • I've just put fix in, and it should be in

  • 2v14.89 ,2v14.92 and 2v14.94 didn't work for the bthrm. I didn't try the 2v14.91 nor the latest ones

  • When/where did you download 2v14.94? I've just checked and there was never a 2v14.94 cutting edge build at¬≠/master

  • Then I got it wrong. I only went into the edge apploader. I'm sure I tried v...89 and v...92. I thought I tried another version, but it seems I have lost track at some point. Sorry for the misunderstanding.

  • I'm delighted to confirm that 2v14.125 works with my bthrm.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

BTHRM issue depending on the firmware version.

Posted by Avatar for Fteacher @Fteacher