BW Clock and hang

Posted on
  • With the last firmware update my B2 went into hang, initially I wanted to blame the firmware, I did a restore from backup which didn't work, two backups from two different dates.
    I restarted from 0 and everything was working until I put "BW Clock" back in and the device crashed again.

    I am using, now I solved by removing this Clock and using another one.

    If it's helpful to anyone.

  • I am not sure about that, but could it be that you are missing the file "weather.json" in the storage area?
    I see that the app is not meant to run without it

  • Thanks! That could be an issue, however it looks like the code is in a try statement.

    If you connect with the Web IDE while running it, do you see any error messages that might help?

  • edit: Nvm, I was wrong about what i posted here.

  • the problem started when I updated the firmware, I have updated it many other times without problem, I confirm that the weather.json file is not present and was not present before the upgrade either.

    @gordon, unfortunately I got it working again on the fly because I needed it right away, I didn't have a chance to test it.
    Next time I'll debug it that way, I hadn't thought of that....


  • I had exactly the same problem, I escaped the hang with a factor reset. After a few fails, I checked the forum find @uname 's post and chunked off BW clock. It works fine now. I've read the forum quickly and didn't see what Gordon suggested to give more data about this issue, sorry.
    I confirm that BW clock previously worked fine without weather.json.

  • Thats really weird. Honestly, I don't think it's the weather.json...

    @Gordon Could it be that an exception is thrown in the "on exit" event and then the firmware calls "on exit" again which again raises an exception such that it is stuck in a loop (on exit -> exception -> on exit -> exception -> ...)? I could easily refactor this to save settings whenever something is changed rather than "on exit" in case this could be the problem and also try catch on exit which would probably a good idea in general... Otherwise I honestly have no idea how this could happen...

  • @PeerDavid can you reproduce this?

    Could it be that an exception is thrown in the "on exit" event and then the firmware calls "on exit" again

    I guess... I wouldn't have thought it was likely from memory, but without looking into it I couldn't say for sure.

    If someone can get me proper steps to reproduce this reliably from a clean Bangle I can look into it...

  • I just tried to reproduce this issue with 2v14.12 but I'm not able to reproduce this.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

BW Clock and hang

Posted by Avatar for uname @uname