Corrosion on new charger point

Posted on
Page
of 2
/ 2
Next
  • Hi just noticed gunk on the charger points of my watch(pic1) .
    Has not been near water ( I'm very careful) or any bad things . When I rubbed it with my finger bits of the copper seemed to of come off (pic 2)
    Is it ok and what could be causing it ? https://ibb.co/DMvqNZg
    https://ibb.co/XCJ8k5k
    Think I did right for pictures.

  • Argh - how long have you had the Bangle?

    There's a note about this on the wiki and Bangle reference: https://www.espruino.com/Bangle.js2#skin­-irritation-warning

    But basically there's a small voltage (3.3v) across the middle two pins for the debug connector. It's extremely low current (0.0001A) but it seems if the back of the Bangle gets salty (I guess from sweat) it can cause corrosion.

    It's kind of strange as I've been wearing one of these for better part of a year and never had issues, but I guess it's not desperately warm here and I haven't been wearing it for any strenuous exercise.

    Will the Bangle still charge ok? If so, please could you put something over the middle two pins? Just a bit of tape, or laquer/nail varnish. It won't affect what you can do with the Bangle at all, but it will totally stop this corrosion.

    I'd have applied something before sending these out, but unfortunately they were pretty much all out the door before I heard from anyone about the issue.

  • Hi Gordon. I got the watch a few weeks ago. It seems to charge ok.
    Thanks for the response.

  • Ok, great - please could you try covering those two middle pads to stop the situation getting worse?

    Sorry about the trouble for this - if we'd known this was an issue beforehand we'd have done it before sending them out, but we've only started to hear about the issue pretty recently.

  • So everyone needs to varnish these contacts? Just in case.

  • So everyone needs to varnish these contacts? Just in case.

    It is SWD debug port, if you are developer building your own native binaries it is handy, if you just write in JS or just use apps you don't need it.

  • Okay! I will not glue them, let's see what will happen to them in the future :)

  • Hey Gordon,

    So I wore my Bangle for the first time out today on a bike ride, and I didn't realise about the contacts being so prone to corrosion.
    I've only got one of the SWD gold dots left, and neither of the charging dots appear to be there - and it's not charging anymore :(

    What can I do to fix this, or is this something that can be replaced under warranty?


    1 Attachment

    • IMG_1428.JPG
  • I've cleaned the contacts up a bit by turning the watch off, then using a cotton tip with isopropyl alcohol to try and remove some of the corrosion on the end 2 contacts.
    I can see a coppery colour now, but it's still not charging.


    1 Attachment

    • IMG_1430.JPG
  • Semi-false alarm! It's charging now!
    The screen was locked, so perhaps the LCARS charge indicator didn't update until the next minute ticked over.
    I'm still concerned that 3 of the 4 contacts have corroded (including the 2 charge ones), and that 1 of the middle ones didn't. I'll stick a piece of tape over all of them for now, and take it off at each charge.

  • @Gordon Maybe a backers update about this would be good...

  • As per my link http://forum.espruino.com/conversations/­370766/#comment16305638
    Update: connecting power is getting hit and miss. I have to "twiddle" the contract to get it to fire up .

  • Argh, sorry about this, but I'm glad you're getting somewhere with it. Yes, I'll post an update soon warning people.

    Hopefully you can clean them up a little more - maybe a mild abrasive like toothpaste, and then make sure you clean it off fully afterwards?

    So what happens with the contacts is they're wired as follows, left-right in the pic above:

    • GND
    • ~10k pulldown to GND
    • ~10k pullup to 3.3v
    • Charge input (effectively slightkly pulled down to GND)

    So I guess it's actually doing some kind of electrolysis - maybe even taking copper off the 'shiny' pin and depositing goop on the other pins. So ironically it's actually only the one shiny pin that you'd have to cover up and then everything would be fine.

  • Mine was happening right away, I used nail polish so it doesn't continue. :)

  • Just took the watch off after a warm day . This photo is prior to cleaning ( I don't have nail polish yet , hoping to buy today) connecting the charger cable is getting a bit of hit or miss . Going to 3d print a holder to see if it is stable connection as jumps in and out of powering up. 😞.


    1 Attachment

    • IMG20211218105312.jpg
  • Cleaned ready for nail polish.
    The photo highlights the copper but they are quite dull except for the left one. The 2 middle ones are non existent or just there. 🤞


    1 Attachment

    • IMG20211218113650.jpg
  • Update . 3d printed the small cradle. (Very nice) . Took about 1 minute of twiddling and got it to start charging . Then stopped then twiddle again and started back up . Question is the nail polish going to help or hinder the charge ?.


    2 Attachments

    • IMG20211218144212.jpg
    • IMG20211218144156.jpg
  • Glad you got it sorted! The nail polish on the middle two pins shouldn't really have any effect on charging. Maybe it'll push the other 2 contacts slightly further from the watch but they are all sprung with over 1mm of movement so you should be ok

  • Just a note on using Sugru for covering the two middle contacts.
    So I thought I'd use sugru and made quite a neat job of covering just the two middle contacts on two bangle2s, and used a bit to fill in the air pressure hole on my one (It's never occurred to me I need to know air pressure!).
    However, after charging I've spotted that the middle two pogo pins are strong enough to poke holes in the sugru (not sure if this was just because I was using out of date Sugru or I didn't knead it well enough, it might be)!
    Anyway, I've noticed before any strenuous exercise (chance would be a fine thing) so I've covered with a bit of tape too, and also strapped up the middle two pogo pins on the charging cable.
    I guess this might happen over time (maybe a year or so?) to soft tape or anything else used to cover the contacts, so might be an idea to use tape to strap up the middle pins too (or check the covering on the contacts)?

  • Had never heard of sugru before. Interesting material...

    I've simply cut a small piece of clear gorilla tape that covers the two middle pins. I can't even see it myself unless I look really close. Have been working flawlessly.

  • Having a closer look at my watch I can see that the gold plating has very small holes, like punched with a needle.
    I suppose that this is caused by Spring Contact Probes (circuit board test needles) used in the factory to program or to test the watch.
    Humidity will go through these holes and cause corrosion in the copper layer, ending up in pushing off the gold plating, only remaining the corroded copper. This will also explain the still gold plated pad(s), the needles did not penetrate their gold layer.
    The factory should use less sharp pointed contact probes to avoid this, for already punched contacts one may try to use Silver Conductive Paint to cover the holes (not yet tested by me).

  • @Gordon :
    In http://forum.espruino.com/conversations/­371622/#comment16340448 you wrote "When the new set of Bangles comes in ..."
    Is there a chance to verify my theory above?

  • Please could you post up a picture of your charge pins? I definitely don't see any small holes in the plating of the contacts on any devices here.

    Sadly I think the issue is more deep seated. As long as there is a voltage there, there is going to be corrosion. Even if the contacts were pure gold all the way through there would still be issues I bet.

  • Sorry for the alarm, here's the "all-clear signal":
    The "holes" were only visible with a strong magnifier, there's no possibility for me to photo it.
    But with the help of my fingernail it turned out that the "holes" are bumps instead!
    So again sorry for the false alarm.

    Maybe the Silver Conductive Paint can prevent the corrosion anyhow?

  • Maybe the Silver Conductive Paint can prevent the corrosion anyhow?

    I'm not sure... Even if it prevents corrosion it could cause some skin irritation. Best bet is to use a sticker or some kind of laquer (like car body touch-up or nail varnish)

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview
About

Corrosion on new charger point

Posted by Avatar for user136815 @user136815

Actions