Bangle.js v2: how to update Firmware?

Posted on
  • How do I update the firmware of my Bangle.js v2?

    It has less buttons than the Bangle.js v1 - thus, the instructions for the old watch should no longer be applicable. However, I could not find new ones.

  • Ahh - I'll make sure that gets added to

    It's basically the same as Bangle.js 1, but since you only have one button you just hold that down for ~10 seconds. When the '====' start going across the screen release the button before they finish and you'll be in bootloader mode

  • That was quick - thank you very much!

  • I'm completely unable to update the firmware.

    One problem seems to be that Nordic has changed how nrf Tools are working on iOS - the one that my Bangle.js v2 always reboots itself after running just a few seconds in DFU mode and I cannot get my iPhone to connect in time.

  • Ahh, I finally managed to connect nrfTools and Bangle.js (don't ask me how, though)

    But now it always tells me: xxx bytes were sent while 0 bytes were reported as received

    Any ideas?

  • Ok, I found out that every retry added approx. 1% of the firmware, so I had to retry approx. 100x in order to get everything sent to my device~~ - at least, it claimed so, but my firmware is still the old one.~~

    Correction: no, it did update my firmware, I just looked at the wrong place. The best place to see the current firmware version is in the Web IDE console after connecting to the watch

  • Thus, my current tips are:

    • if nrfTools give you the message
      xxx bytes were sent while 0 bytes were reported as received
      just retry - even if you have to retry approx. 100 times! (it still only takes a few minutes
    • after completion, connect the Espruino Web IDE with your Bangle.js and check, that the terminal displays the correct (i.e. new) firmware version!
  • Wow, that is odd. It sounds like Nordic broke their own iPhone app :(

    You should be able to flash from the IDE though... I'll change the flasher later today, but right now you can just choose 'Bangle.js' from the list of devices rather than bangle.js 2.

  • I tried as you said, but my bangle rebooted in the middle of the transfer. Nothing bad happened, just the transfer got stuck...

    I then tried again, but with the same result.

    Anyway, my "100-retries-approach" seems to work "reliably" and gives my the bleeding edge firmware (i.e., my thumb is bleeding)

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Bangle.js v2: how to update Firmware?

Posted by Avatar for Andreas_Rozek @Andreas_Rozek