• Here is a Bangle.js 1 watch where the button BTN2 does not do anything.
    It has firmware 2v09. A few things were tried already, see below.

    As BTN2 does not work, so is there a way to flash the firmware without using BTN2?

    Is there a different way to reset or hard reset?

    Anything else I should try to get BTN2 working again?


    • Pressing on BTN2 does not wake up the clock.
    • Does not go into the menu, when pressed short or long, or repeatetly.
    • Does not initiate reset or reset into flashing when pressing to gether with BTN1.


    BTN2 was working so far. Flashed to 2v09 and BTN2 was also working.

    Watch wasn't used much for a few weeks and wasn't switched off, so it is assumed that the battery ran completely low. It did charge fine and came up. Since then BTN2 is not working, and I think the watch could also not be resetted.

    Can connect. Updated all apps. Also tried to reinstall to default apps, this got me a few errors and got stuck. Then erased all apps and installed bootloader, morphing clock, menu and so on. Holding BTN3 reloads, but not reset and no working BTN2.

  • BTN2 can be a problem. If the button is just stuck I use the workaround that I TURN BTN2. In most cases it is working again. Maybe this also solves your problem. Otherwise ... maybe Gordon has an idea ...

  • To expand my question: is there a way to diagnose if BTN2 is physically working and getting the signal to the software, maybe via the development web console?

    @Tx thanks for your suggestion! I've tried turning already without success and I'll try again.

  • is there a way to diagnose if BTN2 is physically working and getting the signal to the software, maybe via the development web console?

    Yes, absolutely - just go to https://www.espruino.com/ide/ and connect, then type:

    BTN2.read() - that'll return the state of the middle button. So you can call it once, then hold the button down and press again, and it should return false first, then true when held down.

    Once logged in you could also try E.reboot() which will initiate a hard reboot. I've never seen this being a problem but if button 2's pin state got messed up I guess it could stop it working, and then if you can't force a reboot with the buttons it'd be hard to recover.

    I know there were some issues a few weeks back when if you'd updated then it could have stopped the middle button working with some clock faces, so it may be that's the issue you're seeing? BTN2 not waking the clock is something that can be configured in settings too.

  • BTN2.read() is always false.

    E.reboot() reboots, but did not change the behaviour.

    As I have removed all apps and reinstalled only a few (that should match the original ones), I only have the morphing clock installed.

    So what is the conclusion: That the second button is broken on the hardware side?
    (It is a bit strange that it falls together with me using the watch the first time in several weeks.)

    Any suggestions?

  • @ber Maybe take it apart and inspect the button for any signs of damage or wear? Just in case...


  • @ber if you rebooted, installed default apps and BTN2.read() is always returning false then yes, it sounds like you have a hardware problem.

    Can you feel a physical 'click' when you press the button in?

    I guess your watch may well be under guarantee so we could arrange a replacement/fix for you, but it could take a few weeks - so as @johan_m_o says it might be worth looking inside if you want it fixed now. More than likely it'll be something simple like alignment between the outside knob and the actual button

  • Can you feel a physical 'click' when you press the button in?

    Yes, though I mean to hear an additional soft rattle, that isn't there with the other two buttons.

    I've bought the watch from https://www.berrybase.de/neu/espruino-ba­ngle.js-smartwatch?c=2478 so I guess they'll be the first contact to handle a replacement/fix. For the fun of it, I'll probably peek inside during a quiet hour.

    Thanks for your support!

  • Honestly, if you go via berrybase they'll just forward it to me, so it might be better to just go direct just to get things done quicker. I'll drop you an email.

  • Meanwhile I had time to disassemble the watch. There were no signs of wear or missalignment. Pressing the actual button directly did not work for BTN2 (whereas it works for BTN1 and BTN3).

    The dis- and reassembly worked well with the instructions of the video.

    Before disassembly after picking up the watch, I'd gotten one BTN2 click where the watch responded. I could not replicate this. Conclusion: There is a hardware problem.

    @Gordon thanks for the wonderful support! As I am in for the Banglejs 2 crowdfunding, my intention is to donate the broken Banglejs 1. I'll reply to your email about how to do this.

  • Wow, thank you! Yes, please drop me an email. I'll try and sort something out for you (like a charge cradle) to try and make up for the Bangle.js 1 issue.

    Someone else asked about what to use their old Bangle.js 1 for, and I'll start a forum post (and maybe a page on the website) about this. I reckon there are still some fun 'static' uses for Bangle.js where BTN2 not working may not really matter.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

BTN2 not working on Bangle1, how to update firmware without button 2?

Posted by Avatar for ber @ber