BLE Keyboard not recognized by Thin Client

Posted on
  • Hi everyone,

    after getting Puck.js working as a BLE keyboard like a charm with my laptop, I now tried to connect to it from a Thin Client. However, other than my laptop and my mobile phone, the thin client does not find Puck.js or maybe ignores it for some unknown reason.

    What irritates me is that if I clone the BLE frame using the NRF Connect app on Android, my phone is recognized by the thin client without a problem.

    I also tried increasing the advertising interval and disabling the UART service. But unfortunately that has no effect either.

    I'm not very deep into bluetooth internals so it might well be that I oversee something important. So if someone has a tipp on where I should tweak a little bit, I would be very grateful!

    Thanks & regards

  • Hi,

    That's a really odd one. Do other Bluetooth devices connect ok to the Thin client?

    It's not that one of your other devices is still left connected to the Puck is it? It can only accept one connection at a time.

    The only thing I can think of right now is maybe the Thin client doesn't like the Bluetooth address of the Puck (which is a 'random' style). That's never been a problem previously but maybe the Thin Client is picky. You could try­setAddress with a public address

  • Hi Gordon,

    yes - I tested it with another bluetooth keyboard and that worked fine. I also tried it with another Puck which wasn't recognized either. And both Pucks were not connected to any other device at the time of testing.

    I will try with another bluetooth address. Hope this helps.

  • Unfortunately it doesn't seem to be the MAC address. Changed it to the one my bluetooth keyboard has (switched that one off of course): nothing. Changed it to a public one: nothing. -_-

    Also: Other devices with random MAC address are recognized correctly.

    Any other idea what could cause this behaviour?

  • The only other thing I can think is maybe it refuses to connect to a device that doesn't have link security enabled. You could follow¬≠skey-pin-pairing and add: NRF.setSecurity({passkey:"123456", mitm:1, display:1});

    However if that were the issue I think you'd still be able to see the device listed, you just wouldn't be able to connect.

    I'm afraid other than that I'm out of ideas.

  • I just tried - it wasn't the link security though. :(

    What irritates me is that it's listed on my desktop PC, my laptop, my Android phone, ... only the Dell thin client doesn't see it. Though when I clone it in the NRF Connect App the cloned "device" gets listed also on the thin client. That's very strange!

    Anyway - thank you very much for your help!! No thanks to Dell though. ;)

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

BLE Keyboard not recognized by Thin Client

Posted by Avatar for 2WeltenChris @2WeltenChris