• Hi there, my bangle had a bit of a meltdown today. I noticed this morning that I could not get into the ActivePedom settings to look at the sensitivity value, just would not go into the settings. Then went to a 3 mile walk with Walkers Watch running GPS / grid ref on and GPS recorder on. When got back could not display a the GPS log from GPS recorder, just came up with a low memory issue in RED. Did a BTN1+BTN2 reboot a few times, no luck. Decided to try a compact - which ran for ages but was NOT interrupted. When it can back it said 'no clock found'. BTN2 would respond and went into TapeLauncher but there appeared to only be about 4 apps (possibly the info files had got lost).

    Connected through IDE and could see the App files were all there. There was however a very large file of about 300KB see screenshot. When downloaded it looked like a concatenation of all files. Decided to rebuild my Bangle, using the App Loader, Delate all apps and install defaults. Then installed favourites.

    I then tried another Compact which did not end after 10 minutes and reset the watch. This time no apparent issues though.

    To be fair I have put my watch through its paces, I have tried almost every App and doing lots of tests and development, manually wrting info files for new apps, getting things wrong etc, so I might have provoked these issues. No necessarily a bad thing to completely reinstall the watch after a week of tinkering :)

    Just wondering if there might be an issue with compact on 2.08.167?

    1 Attachment

    • odd_file.png
  • screenshot from IDE

    1 Attachment

    • compact_problem.png
  • This sounds an awful lot like this issue: https://github.com/espruino/Espruino/iss­ues/1970

    Which was fixed about 2 weeks ago (so maybe not in the 2.08.167 release you had).

    Basically if you were writing to a StorageFile and then the storage was compacted, the Storagefile address would end up being wrong and it'd end up writing to the middle of other files.

    Normally that's not an issue since if there's compaction it'd be cause because of a StorageFile write, and in that case it's fine. However if you were really unlucky and changing settings, or you were writing to two StorageFiles at the same time, it could happen

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

2.08.167, ended up with no clock, apps detected after compact appear to crash

Posted by Avatar for HughB @HughB