• I thought that I'd lost my Bangle device today. I came in to see a series of messages on the display, something like:

    -> Bluetooth
    <- Bluetooth
    -> Bluetooth
    <- Bluetooth

    I tried rebooting, and got as far as the logo/version/mac display, then -> Bluetooth again. I tried powering off, resetting, finally I even reloaded the firmware via DFU, everything I tried seemed to "succeed" but I still got nothing after the initial logo. I was not able to try any of the "load default apps" or "reload the bootloader" or anything from the app store because my laptop couldn't pair to the watch. But obviously the Bluetooth hardware was working because DFU worked.

    I investigated and I'm presuming that the -> Bluetooth messages are related to console redirection, based on a quick grep of the espruino sources? So maybe -> Bluetooth was when my phone connected to the watch, and <- Bluetooth was when it went out of range?

    Obviously, I finally thought to disable Bluetooth on my phone, which made it possible to pair to my laptop, and I was able to reload things and it's working fine now.

    So, ultimately, I wanted to remind people that Gadgetbridge is annoyingly aggressive in connecting to the Bangle, if you're having problems connecting to your watch, even if you think you've broken it, don't forget to turn it off.

    Also, if anyone has any thoughts about what might have gone wrong, I'd love to hear them.


  • Thanks for the update! Sometimes this can happen if you'd got HID (bluetooth keyboard) turned on in Bangle.js settings, and then you turn it off - the device that was connected can keep trying to connect, failing, and doing it again.

    But it might also be related to Gadgetbridge as you say - I think it's possible that if you choose to pair when prompted (you don't have to), if for some reason Bangle.js loses the encryption keys, Gadgetbridge will just keep retrying the connection

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

What causes failure to boot with "-> Bluetooth" "<- Bluetooth" messages?

Posted by Avatar for zdooder @zdooder