Console spam error

Posted on
  • When uploading via bluetooth code using web ide.

    Uncaught Error: I2C Error: Arbitration (start)
    

    is spammed in console ide. Using relay, with latest firmware bleeding edge.

    Not sure what the issue is, uploading seems hit and miss on the store too. I decided to reinstall all default apps for now. Until i feel more confident with the firmware.

    It seems the data in the flash was becoming corrupted.

    It struggles to upload 'settings' app under 'install default apps', when it gets to the setting app, it fails often.

  • Any chance you could try running the battery down until it turns off, and then charging up again? If you can get in via the Web IDE and do: Bangle.setLCDPower(1);Bangle.setLCDTimeo¬≠ut(0);Bangle.setGPSPower(1);Bangle.setHR¬≠MPower(1) it should run the battery down pretty quick (Maybe 4-5 hours).

    I'm not 100% sure why but it seems that your accelerometer chip may have 'crashed'. I've only had this once before, but in that case we couldn't reset it with a software reset and we basically just had to power cycle it.

    After that it was perfect though.

  • Ye i will do that. Btw is this related to :

    Bangle.accelWr(0x18,0x0A);

    I put that in my .boot0 file , hm.

  • Ahh - that might not be helping matters. I guess it's possible (I'm not sure how) that it gets called before the accelerometer initialises.

    Worth removing it and seeing if it fixes things (especially as cutting edge builds are so much better now - see the latest update).

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview
About

Console spam error

Posted by Avatar for d3nd3-o0 @d3nd3-o0

Actions