Upload Failed Unexpected Response

Posted on
  • Hi

    I tried to update from Chrome v83 today and I got problems.

    First it failed in updating 6 apps, then when I tried again it complained something about unexpected data.

    I lost the settings page after I tried to turn Debug on (it just froze) so I then I deleted all the apps that it wanted to update including Launcher. Now I try and reinstall the Launcher and I see

    "Upload failed, Unexpected Response " then a square box then "[?7l"

    What does this mean?

    I tried rebooting etc. Did something change in the Web app? Do I need to turn debug off?


  • You might have hit this: https://www.espruino.com/Troubleshooting­+Bangle.js#i-can-t-upload-apps-and-the-i­de-just-says-terminal-when-connected


    I can't upload apps, and the IDE just says -> Terminal when connected

    On Firmwares shipped on KickStarter Bangle.js there was a bug. Please leave Debug Info set to Hide (the default) in Bangle.js's Settings, then update to the latest Bootloader version using https://banglejs.com/apps (which will allow everything to work even with Debug Info set to Show).


    Or had you updated everything previously?

    I don't believe anything has changed recently in the app loader that would have caused issues. Maybe you could try doing the "Reset without loading code" at https://www.espruino.com/Bangle.js#reset­ting-without-loading-any-code ?

  • Thanks for the info. In the end I had to:

    Reset without loading any code
    Utilities Remove All Apps/Install Default Apps
    Reinstall apps

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Upload Failed Unexpected Response

Posted by Avatar for user115080 @user115080